<!doctype html>
<!--[if lt IE 7 ]> <html class="no-js ie6" lang="en-US"> <![endif]-->
<!--[if IE 7 ]>    <html class="no-js ie7" lang="en-US"> <![endif]-->
<!--[if IE 8 ]>    <html class="no-js ie8" lang="en-US"> <![endif]-->
<!--[if (gte IE 9)|!(IE)]><!--> <html class="no-js" lang="en-US"> <!--<![endif]-->
<head>
<meta charset="UTF-8" />
<meta name="viewport" content="width=device-width, user-scalable=no, initial-scale=1.0, minimum-scale=1.0, maximum-scale=1.0">
<meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1" />
<link rel="icon" type="image/png" href="https://psxextreme.com/wp-content/uploads/2018/03/favicon.ico" />
<link rel="profile" href="https://gmpg.org/xfn/11" />
<link rel="pingback" href="https://psxextreme.com/xmlrpc.php" />
<style>
/* Custom BSA_PRO Styles */
/* fonts */
/* form */
.bsaProOrderingForm {   }
.bsaProInput input,
.bsaProInput input[type='file'],
.bsaProSelectSpace select,
.bsaProInputsRight .bsaInputInner,
.bsaProInputsRight .bsaInputInner label {   }
.bsaProPrice  {  }
.bsaProDiscount  {   }
.bsaProOrderingForm .bsaProSubmit,
.bsaProOrderingForm .bsaProSubmit:hover,
.bsaProOrderingForm .bsaProSubmit:active {   }
/* alerts */
.bsaProAlert,
.bsaProAlert > a,
.bsaProAlert > a:hover,
.bsaProAlert > a:focus {  }
.bsaProAlertSuccess {  }
.bsaProAlertFailed {  }
/* stats */
.bsaStatsWrapper .ct-chart .ct-series.ct-series-b .ct-bar,
.bsaStatsWrapper .ct-chart .ct-series.ct-series-b .ct-line,
.bsaStatsWrapper .ct-chart .ct-series.ct-series-b .ct-point,
.bsaStatsWrapper .ct-chart .ct-series.ct-series-b .ct-slice.ct-donut { stroke: #673AB7 !important; }
.bsaStatsWrapper  .ct-chart .ct-series.ct-series-a .ct-bar,
.bsaStatsWrapper .ct-chart .ct-series.ct-series-a .ct-line,
.bsaStatsWrapper .ct-chart .ct-series.ct-series-a .ct-point,
.bsaStatsWrapper .ct-chart .ct-series.ct-series-a .ct-slice.ct-donut { stroke: #FBCD39 !important; }
/* Custom CSS */
</style><!-- Jetpack Site Verification Tags -->
<meta name="google-site-verification" content="fnbeTeHKrpZYN-DiXrao_uoz3xseQvGYyIsSh-3ibH8" />
<!-- This site is optimized with the Yoast SEO plugin v15.2 - https://yoast.com/wordpress/plugins/seo/ -->
<title>PlayStation 2 20th Anniversary Retrospective - PSX Extreme</title>
<meta name="robots" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
<link rel="canonical" href="https://psxextreme.com/news/playstation-2-20th-anniversary-retrospective/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="PlayStation 2 20th Anniversary Retrospective - PSX Extreme" />
<meta property="og:description" content="The PlayStation 2, in addition to still reigning supreme as the best-selling gaming console of all time, is one of the most beloved platforms in history. With, arguably, the most dominant lineup of AAA platform-exclusive games ever, the PS2&#8217;s fanbase&hellip; Read more &#8250;" />
<meta property="og:url" content="https://psxextreme.com/news/playstation-2-20th-anniversary-retrospective/" />
<meta property="og:site_name" content="PSX Extreme" />
<meta property="article:publisher" content="https://www.facebook.com/PSXExtreme/" />
<meta property="article:published_time" content="2020-10-30T02:36:42+00:00" />
<meta property="article:modified_time" content="2020-10-30T02:47:35+00:00" />
<meta property="og:image" content="https://i2.wp.com/psxextreme.com/wp-content/uploads/2020/10/ps2logo.jpg?fit=1920%2C1080&#038;ssl=1" />
<meta property="og:image:width" content="1920" />
<meta property="og:image:height" content="1080" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:creator" content="@PSXExtreme" />
<meta name="twitter:site" content="@PSXExtreme" />
<meta name="twitter:label1" value="Written by">
<meta name="twitter:data1" value="Alex Moretti">
<meta name="twitter:label2" value="Est. reading time">
<meta name="twitter:data2" value="9 minutes">
<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://psxextreme.com/#organization","name":"PSX Extreme","url":"https://psxextreme.com/","sameAs":["https://www.facebook.com/PSXExtreme/","https://twitter.com/PSXExtreme"],"logo":{"@type":"ImageObject","@id":"https://psxextreme.com/#logo","inLanguage":"en-US","url":"https://i1.wp.com/psxextreme.com/wp-content/uploads/2018/03/dark-logo.png?fit=258%2C80&ssl=1","width":258,"height":80,"caption":"PSX Extreme"},"image":{"@id":"https://psxextreme.com/#logo"}},{"@type":"WebSite","@id":"https://psxextreme.com/#website","url":"https://psxextreme.com/","name":"PSX Extreme","description":"PS4 News, PlayStation VR News, PS5 News and Game Reviews,","publisher":{"@id":"https://psxextreme.com/#organization"},"potentialAction":[{"@type":"SearchAction","target":"https://psxextreme.com/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://psxextreme.com/news/playstation-2-20th-anniversary-retrospective/#primaryimage","inLanguage":"en-US","url":"https://i2.wp.com/psxextreme.com/wp-content/uploads/2020/10/ps2logo.jpg?fit=1920%2C1080&ssl=1","width":1920,"height":1080},{"@type":"WebPage","@id":"https://psxextreme.com/news/playstation-2-20th-anniversary-retrospective/#webpage","url":"https://psxextreme.com/news/playstation-2-20th-anniversary-retrospective/","name":"PlayStation 2 20th Anniversary Retrospective - PSX Extreme","isPartOf":{"@id":"https://psxextreme.com/#website"},"primaryImageOfPage":{"@id":"https://psxextreme.com/news/playstation-2-20th-anniversary-retrospective/#primaryimage"},"datePublished":"2020-10-30T02:36:42+00:00","dateModified":"2020-10-30T02:47:35+00:00","inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://psxextreme.com/news/playstation-2-20th-anniversary-retrospective/"]}]},{"@type":"Article","@id":"https://psxextreme.com/news/playstation-2-20th-anniversary-retrospective/#article","isPartOf":{"@id":"https://psxextreme.com/news/playstation-2-20th-anniversary-retrospective/#webpage"},"author":{"@id":"https://psxextreme.com/#/schema/person/45ca1c82e02954d876f1bb5f0a1befe6"},"headline":"PlayStation 2 20th Anniversary Retrospective","datePublished":"2020-10-30T02:36:42+00:00","dateModified":"2020-10-30T02:47:35+00:00","mainEntityOfPage":{"@id":"https://psxextreme.com/news/playstation-2-20th-anniversary-retrospective/#webpage"},"commentCount":0,"publisher":{"@id":"https://psxextreme.com/#organization"},"image":{"@id":"https://psxextreme.com/news/playstation-2-20th-anniversary-retrospective/#primaryimage"},"keywords":"20th anniversary,dmc,god of war,gta,guitar hero,mgs,Persona,ps2,sony","articleSection":"Feature,News","inLanguage":"en-US","potentialAction":[{"@type":"CommentAction","name":"Comment","target":["https://psxextreme.com/news/playstation-2-20th-anniversary-retrospective/#respond"]}]},{"@type":"Person","@id":"https://psxextreme.com/#/schema/person/45ca1c82e02954d876f1bb5f0a1befe6","name":"Alex Moretti","image":{"@type":"ImageObject","@id":"https://psxextreme.com/#personlogo","inLanguage":"en-US","url":"//www.gravatar.com/avatar/fd178ba9b417d319df51ec0f1a97d587?s=96&#038;r=g&#038;d=mm","caption":"Alex Moretti"}}]}</script>
<!-- / Yoast SEO plugin. -->
<link rel='dns-prefetch' href='//www.google.com' />
<link rel='dns-prefetch' href='//cdn.jsdelivr.net' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel='dns-prefetch' href='//i0.wp.com' />
<link rel='dns-prefetch' href='//i1.wp.com' />
<link rel='dns-prefetch' href='//i2.wp.com' />
<link rel='dns-prefetch' href='//c0.wp.com' />
<link rel="alternate" type="application/rss+xml" title="PSX Extreme &raquo; Feed" href="https://psxextreme.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="PSX Extreme &raquo; Comments Feed" href="https://psxextreme.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="PSX Extreme &raquo; PlayStation 2 20th Anniversary Retrospective Comments Feed" href="https://psxextreme.com/news/playstation-2-20th-anniversary-retrospective/feed/" />
<script type="text/javascript">
window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/psxextreme.com\/wp-includes\/js\/wp-emoji-release.min.js"}};
!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,8205,55356,57212],[55357,56424,8203,55356,57212])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
display: inline !important;
border: none !important;
box-shadow: none !important;
height: 1em !important;
width: 1em !important;
margin: 0 .07em !important;
vertical-align: -0.1em !important;
background: none !important;
padding: 0 !important;
}
</style>
<style type="text/css" media="all">
.wpautoterms-footer{background-color:#ffffff;text-align:center;}
.wpautoterms-footer a{color:#000000;font-family:Arial, sans-serif;font-size:14px;}
.wpautoterms-footer .separator{color:#cccccc;font-family:Arial, sans-serif;font-size:14px;}</style>
<!-- <link rel='stylesheet' id='cnss_font_awesome_css-css'  href='https://psxextreme.com/wp-content/plugins/easy-social-icons/css/font-awesome/css/all.min.css' type='text/css' media='all' /> -->
<!-- <link rel='stylesheet' id='cnss_font_awesome_v4_shims-css'  href='https://psxextreme.com/wp-content/plugins/easy-social-icons/css/font-awesome/css/v4-shims.min.css' type='text/css' media='all' /> -->
<!-- <link rel='stylesheet' id='cnss_css-css'  href='https://psxextreme.com/wp-content/plugins/easy-social-icons/css/cnss.css' type='text/css' media='all' /> -->
<!-- <link rel='stylesheet' id='pt-cv-public-style-css'  href='https://psxextreme.com/wp-content/plugins/content-views-query-and-display-post-page/public/assets/css/cv.css' type='text/css' media='all' /> -->
<!-- <link rel='stylesheet' id='pt-cv-public-pro-style-css'  href='https://psxextreme.com/wp-content/plugins/pt-content-views-pro/public/assets/css/cvpro.min.css' type='text/css' media='all' /> -->
<link rel="stylesheet" type="text/css" href="//psxextreme.com/wp-content/cache/wpfc-minified/q6luvknf/b0n4.css" media="all"/>
<link rel='stylesheet' id='wp-block-library-css'  href='https://c0.wp.com/c/5.5.2/wp-includes/css/dist/block-library/style.min.css' type='text/css' media='all' />
<style id='wp-block-library-inline-css' type='text/css'>
.has-text-align-justify{text-align:justify;}
</style>
<!-- <link rel='stylesheet' id='bp-member-block-css'  href='https://psxextreme.com/wp-content/plugins/buddypress/bp-members/css/blocks/member.min.css' type='text/css' media='all' /> -->
<!-- <link rel='stylesheet' id='bp-group-block-css'  href='https://psxextreme.com/wp-content/plugins/buddypress/bp-groups/css/blocks/group.min.css' type='text/css' media='all' /> -->
<!-- <link rel='stylesheet' id='wpautoterms_css-css'  href='https://psxextreme.com/wp-content/plugins/auto-terms-of-service-and-privacy-policy/css/wpautoterms.css' type='text/css' media='all' /> -->
<!-- <link rel='stylesheet' id='bbp-default-css'  href='https://psxextreme.com/wp-content/plugins/bbpress/templates/default/css/bbpress.min.css' type='text/css' media='all' /> -->
<!-- <link rel='stylesheet' id='buy_sell_ads_pro_main_stylesheet-css'  href='https://psxextreme.com/wp-content/plugins/bsa-plugin-pro-scripteo/frontend/css/asset/style.css?v=4.3.22' type='text/css' media='all' /> -->
<!-- <link rel='stylesheet' id='buy_sell_ads_pro_user_panel-css'  href='https://psxextreme.com/wp-content/plugins/bsa-plugin-pro-scripteo/frontend/css/asset/user-panel.css' type='text/css' media='all' /> -->
<!-- <link rel='stylesheet' id='buy_sell_ads_pro_template_stylesheet-css'  href='https://psxextreme.com/wp-content/plugins/bsa-plugin-pro-scripteo/frontend/css/all.css' type='text/css' media='all' /> -->
<!-- <link rel='stylesheet' id='buy_sell_ads_pro_animate_stylesheet-css'  href='https://psxextreme.com/wp-content/plugins/bsa-plugin-pro-scripteo/frontend/css/asset/animate.css' type='text/css' media='all' /> -->
<!-- <link rel='stylesheet' id='buy_sell_ads_pro_chart_stylesheet-css'  href='https://psxextreme.com/wp-content/plugins/bsa-plugin-pro-scripteo/frontend/css/asset/chart.css' type='text/css' media='all' /> -->
<!-- <link rel='stylesheet' id='buy_sell_ads_pro_carousel_stylesheet-css'  href='https://psxextreme.com/wp-content/plugins/bsa-plugin-pro-scripteo/frontend/css/asset/bsa.carousel.css' type='text/css' media='all' /> -->
<!-- <link rel='stylesheet' id='buy_sell_ads_pro_materialize_stylesheet-css'  href='https://psxextreme.com/wp-content/plugins/bsa-plugin-pro-scripteo/frontend/css/asset/material-design.css' type='text/css' media='all' /> -->
<!-- <link rel='stylesheet' id='jquery-ui-css'  href='https://psxextreme.com/wp-content/plugins/bsa-plugin-pro-scripteo/frontend/css/asset/ui-datapicker.css' type='text/css' media='all' /> -->
<link rel="stylesheet" type="text/css" href="//psxextreme.com/wp-content/cache/wpfc-minified/kptsxoht/b0n4.css" media="all"/>
<link rel='stylesheet' id='dashicons-css'  href='https://c0.wp.com/c/5.5.2/wp-includes/css/dashicons.min.css' type='text/css' media='all' />
<!-- <link rel='stylesheet' id='bp-nouveau-css'  href='https://psxextreme.com/wp-content/plugins/buddypress/bp-templates/bp-nouveau/css/buddypress.min.css' type='text/css' media='screen' /> -->
<link rel="stylesheet" type="text/css" href="//psxextreme.com/wp-content/cache/wpfc-minified/la97acg4/b0n4.css" media="screen"/>
<!-- <link rel='stylesheet' id='contact-form-7-css'  href='https://psxextreme.com/wp-content/plugins/contact-form-7/includes/css/styles.css' type='text/css' media='all' /> -->
<!-- <link rel='stylesheet' id='psxextreme-ratings-css-css'  href='https://psxextreme.com/wp-content/plugins/psxextreme_ratings_plugin/Plugin/media/psxextreme-ratings-css.css' type='text/css' media='all' /> -->
<!-- <link rel='stylesheet' id='widgets-on-pages-css'  href='https://psxextreme.com/wp-content/plugins/widgets-on-pages/public/css/widgets-on-pages-public.css' type='text/css' media='all' /> -->
<!-- <link rel='stylesheet' id='wp-polls-css'  href='https://psxextreme.com/wp-content/plugins/wp-polls/polls-css.css' type='text/css' media='all' /> -->
<link rel="stylesheet" type="text/css" href="//psxextreme.com/wp-content/cache/wpfc-minified/er0yo7mh/b0n4.css" media="all"/>
<style id='wp-polls-inline-css' type='text/css'>
.wp-polls .pollbar {
margin: 1px;
font-size: 6px;
line-height: 8px;
height: 8px;
background-image: url('https://psxextreme.com/wp-content/plugins/wp-polls/images/default/pollbg.gif');
border: 1px solid #c8c8c8;
}
</style>
<!-- <link rel='stylesheet' id='wpdiscuz-frontend-css-css'  href='https://psxextreme.com/wp-content/plugins/wpdiscuz/themes/default/style.css' type='text/css' media='all' /> -->
<link rel="stylesheet" type="text/css" href="//psxextreme.com/wp-content/cache/wpfc-minified/qhvc7679/b0nj.css" media="all"/>
<style id='wpdiscuz-frontend-css-inline-css' type='text/css'>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</style>
<!-- <link rel='stylesheet' id='wpdiscuz-fa-css'  href='https://psxextreme.com/wp-content/plugins/wpdiscuz/assets/third-party/font-awesome-5.13.0/css/fa.min.css' type='text/css' media='all' /> -->
<!-- <link rel='stylesheet' id='wpdiscuz-combo-css-css'  href='https://psxextreme.com/wp-content/plugins/wpdiscuz/assets/css/wpdiscuz-combo.min.css' type='text/css' media='all' /> -->
<!-- <link rel='stylesheet' id='bootstrap-styles-css'  href='https://psxextreme.com/wp-content/themes/psx/css/layouts/cosmo.min.css' type='text/css' media='all' /> -->
<!-- <link rel='stylesheet' id='font-awesome-css'  href='https://psxextreme.com/wp-content/themes/psx/css/font-awesome.min.css' type='text/css' media='all' /> -->
<!-- <link rel='stylesheet' id='responsive-style-css'  href='https://psxextreme.com/wp-content/themes/psx/style.css' type='text/css' media='all' /> -->
<!-- <link rel='stylesheet' id='newsletter-css'  href='https://psxextreme.com/wp-content/plugins/newsletter/style.css' type='text/css' media='all' /> -->
<link rel="stylesheet" type="text/css" href="//psxextreme.com/wp-content/cache/wpfc-minified/1ptxe72x/b0nj.css" media="all"/>
<link rel='stylesheet' id='jetpack_css-css'  href='https://c0.wp.com/p/jetpack/9.0.2/css/jetpack.css' type='text/css' media='all' />
<script type='text/javascript' src='https://c0.wp.com/c/5.5.2/wp-includes/js/jquery/jquery.js' id='jquery-core-js'></script>
<script src='//psxextreme.com/wp-content/cache/wpfc-minified/km7rpocz/b0n4.js' type="text/javascript"></script>
<!-- <script type='text/javascript' src='https://psxextreme.com/wp-content/plugins/easy-social-icons/js/cnss.js' id='cnss_js-js'></script> -->
<script type='text/javascript' id='jetpack_related-posts-js-extra'>
/* <![CDATA[ */
var related_posts_js_options = {"post_heading":"h4"};
/* ]]> */
</script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/9.0.2/_inc/build/related-posts/related-posts.min.js' id='jetpack_related-posts-js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.5.2/wp-includes/js/dist/vendor/wp-polyfill.min.js' id='wp-polyfill-js'></script>
<script type='text/javascript' id='wp-polyfill-js-after'>
( 'fetch' in window ) || document.write( '<script src="https://psxextreme.com/wp-includes/js/dist/vendor/wp-polyfill-fetch.min.js"></scr' + 'ipt>' );( document.contains ) || document.write( '<script src="https://psxextreme.com/wp-includes/js/dist/vendor/wp-polyfill-node-contains.min.js"></scr' + 'ipt>' );( window.DOMRect ) || document.write( '<script src="https://psxextreme.com/wp-includes/js/dist/vendor/wp-polyfill-dom-rect.min.js"></scr' + 'ipt>' );( window.URL && window.URL.prototype && window.URLSearchParams ) || document.write( '<script src="https://psxextreme.com/wp-includes/js/dist/vendor/wp-polyfill-url.min.js"></scr' + 'ipt>' );( window.FormData && window.FormData.prototype.keys ) || document.write( '<script src="https://psxextreme.com/wp-includes/js/dist/vendor/wp-polyfill-formdata.min.js"></scr' + 'ipt>' );( Element.prototype.matches && Element.prototype.closest ) || document.write( '<script src="https://psxextreme.com/wp-includes/js/dist/vendor/wp-polyfill-element-closest.min.js"></scr' + 'ipt>' );
</script>
<script type='text/javascript' src='https://c0.wp.com/c/5.5.2/wp-includes/js/dist/dom-ready.min.js' id='wp-dom-ready-js'></script>
<script src='//psxextreme.com/wp-content/cache/wpfc-minified/jzwf987k/b0n4.js' type="text/javascript"></script>
<!-- <script type='text/javascript' src='https://psxextreme.com/wp-content/plugins/auto-terms-of-service-and-privacy-policy/js/base.js' id='wpautoterms_base-js'></script> -->
<script type='text/javascript' id='thickbox-js-extra'>
/* <![CDATA[ */
var thickboxL10n = {"next":"Next >","prev":"< Prev","image":"Image","of":"of","close":"Close","noiframes":"This feature requires inline frames. You have iframes disabled or your browser does not support them.","loadingAnimation":"https:\/\/psxextreme.com\/wp-includes\/js\/thickbox\/loadingAnimation.gif"};
/* ]]> */
</script>
<script type='text/javascript' src='https://c0.wp.com/c/5.5.2/wp-includes/js/thickbox/thickbox.js' id='thickbox-js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.5.2/wp-includes/js/underscore.min.js' id='underscore-js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.5.2/wp-includes/js/shortcode.min.js' id='shortcode-js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.5.2/wp-admin/js/media-upload.min.js' id='media-upload-js'></script>
<script src='//psxextreme.com/wp-content/cache/wpfc-minified/jy4hlg6w/b0n4.js' type="text/javascript"></script>
<!-- <script type='text/javascript' src='https://psxextreme.com/wp-content/plugins/bsa-plugin-pro-scripteo/frontend/js/script.js' id='buy_sell_ads_pro_js_script-js'></script> -->
<!-- <script type='text/javascript' src='https://psxextreme.com/wp-content/plugins/bsa-plugin-pro-scripteo/frontend/js/jquery.viewportchecker.js' id='buy_sell_ads_pro_viewport_checker_js_script-js'></script> -->
<!-- <script type='text/javascript' src='https://psxextreme.com/wp-content/plugins/bsa-plugin-pro-scripteo/frontend/js/chart.js' id='buy_sell_ads_pro_chart_js_script-js'></script> -->
<!-- <script type='text/javascript' src='https://psxextreme.com/wp-content/plugins/bsa-plugin-pro-scripteo/frontend/js/bsa.carousel.js' id='buy_sell_ads_pro_carousel_js_script-js'></script> -->
<!-- <script type='text/javascript' src='https://psxextreme.com/wp-content/plugins/bsa-plugin-pro-scripteo/frontend/js/jquery.simplyscroll.js' id='buy_sell_ads_pro_simply_scroll_js_script-js'></script> -->
<!-- <script type='text/javascript' src='https://psxextreme.com/wp-content/plugins/buddypress/bp-core/js/widget-members.min.js' id='bp-widget-members-js'></script> -->
<!-- <script type='text/javascript' src='https://psxextreme.com/wp-content/plugins/buddypress/bp-core/js/jquery-query.min.js' id='bp-jquery-query-js'></script> -->
<!-- <script type='text/javascript' src='https://psxextreme.com/wp-content/plugins/buddypress/bp-core/js/vendor/jquery-cookie.min.js' id='bp-jquery-cookie-js'></script> -->
<!-- <script type='text/javascript' src='https://psxextreme.com/wp-content/plugins/buddypress/bp-core/js/vendor/jquery-scroll-to.min.js' id='bp-jquery-scroll-to-js'></script> -->
<!-- <script type='text/javascript' src='https://psxextreme.com/wp-content/themes/psx/js/imagesloaded.pkgd.min.js' id='imagesloaded-script-js'></script> -->
<!-- <script type='text/javascript' src='https://psxextreme.com/wp-content/themes/psx/js/bootstrap.js' id='bootstrap-script-js'></script> -->
<!-- <script type='text/javascript' src='https://psxextreme.com/wp-content/themes/psx/js/strap-extras.js' id='strap-extras-script-js'></script> -->
<link rel="https://api.w.org/" href="https://psxextreme.com/wp-json/" /><link rel="alternate" type="application/json" href="https://psxextreme.com/wp-json/wp/v2/posts/48120" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://psxextreme.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://psxextreme.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.5.2" />
<link rel='shortlink' href='https://psxextreme.com/?p=48120' />
<link rel="alternate" type="application/json+oembed" href="https://psxextreme.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fpsxextreme.com%2Fnews%2Fplaystation-2-20th-anniversary-retrospective%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://psxextreme.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fpsxextreme.com%2Fnews%2Fplaystation-2-20th-anniversary-retrospective%2F&#038;format=xml" />
<script type="text/javascript">var ajaxurl = 'https://psxextreme.com/wp-admin/admin-ajax.php';</script>
<style>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</style>
<style type="text/css">
ul.cnss-social-icon li.cn-fa-icon a:hover{opacity: 0.7!important;color:#ffffff!important;}
</style><style type="text/css">.wp_autosearch_suggestions {border-width: 1px;border-color: #57C297 !important;border-style: solid;width: 190px;background-color: #a0a0a0;font-size: 10px;line-height: 14px;border: none !important;}.wp_autosearch_suggestions a {display: block;clear: left;text-decoration: none;}.wp_autosearch_suggestions a img {float: left;padding: 3px 5px;}.wp_autosearch_suggestions a .searchheading {display: block;font-weight: bold;padding-top: 5px;}.wp_autosearch_suggestions .wps_odd a {color: #000000;}.wp_autosearch_suggestions .wps_even a {color: #000000;}.wp_autosearch_suggestions .wp_autosearch_category {font-size: 12px;padding: 5px;display: block;background-color: #5286A0 !important;color: #FFFFFF !important;}.wps_over a.wp_autosearch_category{color: #FFFFFF !important;background-color: 6A81A0 !important;}.wp_autosearch_suggestions .wp_autosearch_more {padding: 5px;display: block;background-color: #5286A0 !important;color: #FFFFFF !important;background-image: url(https://psxextreme.com/wp-content/plugins/wp-autosearch//assert/image/arrow.png);background-repeat: no-repeat;background-position: 99% 50%;cursor: pointer;}.wps_over a.wp_autosearch_more{color: #FFFFFF !important;background-color: #4682A0 !important;}.wp_autosearch_suggestions .wp_autosearch_more a {height: auto;color: #FFFFFF !important;}.wp_autosearch_image {margin: 2px;}.wp_autosearch_result {padding-left: 5px;}.wp_autosearch_indicator {background: url('https://psxextreme.com/wp-content/plugins/wp-autosearch//assert/image/indicator.gif') no-repeat scroll 100% 50% #FFF !important;}.wp_autosearch_suggestions {padding: 0px;background-color: white;overflow: hidden;z-index: 99999;}.wp_autosearch_suggestions ul {width: 100%;list-style-position: outside;list-style: none;padding: 0;margin: 0;}.wp_autosearch_suggestions li {margin: 0px;cursor: pointer;display: block;font: menu;font-size: 12px;line-height: 16px;overflow: hidden;}.wps_odd {background-color: #FFFFFF;}.wps_even {background-color: #E8E8E8;}.ac_over {background-color: #034478;color: #FFFFFF !important;}.ac_over a, .ac_over a span {color: #FFFFFF !important;}.wp_autosearch_input{width: 88% !important;height: 50px !important;border: none !important;background-color: #FFFFFF !important;outline: none;box-shadow: 0px 0px 0px #FFF !important;-moz-box-shadow: 0px 0px 0px #FFF !important;-webkit-box-shadow: 0px 0px 0px #FFF !important;text-indent: 5px !important;margin: 0 !important;padding: 0 !important;overflow: hidden;float: left;line-height: 29px;vertical-align: middle;color: #000000 !important;}.wp_autosearch_wrapper{width: 100%;}.wp_autosearch_suggestions{box-shadow: #888888 5px 10px 10px;-webkit-box-shadow: #888888 5px 10px 10px;}.wp_autosearch_submit, .wp_autosearch_submit:hover, .wp_autosearch_submit:active, .wp_autosearch_submit:visited{cursor: pointer;height: 50px;width: 54px;overflow: hidden;background: transparent url('') no-repeat scroll !important;float: right;font-size: 100%;-webkit-appearance: none;outline: none;position: absolute;right: 0px;top: 0px;background-color: transparent;border: none ;border-radius: 0 !important;padding: 0 !important;margin: 0 !important;display: block !important;}.wp_autosearch_form_wrapper{width: 100%;border: 1px solid #57C297 !important;height: 52px !important;background-color: #FFFFFF !important;position: relative;}.wp_autosearch_item_description{padding-right: 2px;padding-left: 2px;}.wp_autosearch_form_label{display: none;}</style><style type="text/css" media="screen">.wp_autosearch_submit, .wp_autosearch_submit:hover, .wp_autosearch_submit:active, .wp_autosearch_submit:visited {
cursor: pointer;
height: 50px;
width: 54px;
overflow: hidden;
background: #1e2836 !important;
float: right;
font-size: 100%;
-webkit-appearance: none;
outline: none;
position: absolute;
right: 0px;
top: 0px;
background-color: #1e2836;
border: none;
color:#fff;
border-radius: 0 !important;
padding: 0 !important;
margin: 0 !important;
display: block !important;
}
.wp_autosearch_form_wrapper {
width: 100%;
border: 1px solid #ddd !important;
height: 52px !important;
background-color: #FFFFFF !important;
position: relative;
}</style><style type='text/css'>img#wpstats{display:none}</style><!-- Custom CSS -->
<style type="text/css">
</style><!-- Global site tag (gtag.js) - Google Analytics -->
<script async src="https://www.googletagmanager.com/gtag/js?id=UA-97641915-1"></script>
<script>
window.dataLayer = window.dataLayer || [];
function gtag(){dataLayer.push(arguments);}
gtag('js', new Date());
gtag('config', 'UA-97641915-1');
</script>
<meta name="generator" content="Powered by WPBakery Page Builder - drag and drop page builder for WordPress."/>
<style type="text/css" id="custom-background-css">
body.custom-background { background-color: #e7e6e6; }
</style>
<style type="text/css">
/* If html does not have either class, do not show lazy loaded images. */
html:not( .jetpack-lazy-images-js-enabled ):not( .js ) .jetpack-lazy-image {
display: none;
}
</style>
<script>
document.documentElement.classList.add(
'jetpack-lazy-images-js-enabled'
);
</script>
<link rel="icon" href="https://i0.wp.com/psxextreme.com/wp-content/uploads/2018/11/cropped-10830088_794658207268173_5582883227963338728_o.jpg?fit=32%2C32&#038;ssl=1" sizes="32x32" />
<link rel="icon" href="https://i0.wp.com/psxextreme.com/wp-content/uploads/2018/11/cropped-10830088_794658207268173_5582883227963338728_o.jpg?fit=192%2C192&#038;ssl=1" sizes="192x192" />
<link rel="apple-touch-icon" href="https://i0.wp.com/psxextreme.com/wp-content/uploads/2018/11/cropped-10830088_794658207268173_5582883227963338728_o.jpg?fit=180%2C180&#038;ssl=1" />
<meta name="msapplication-TileImage" content="https://i0.wp.com/psxextreme.com/wp-content/uploads/2018/11/cropped-10830088_794658207268173_5582883227963338728_o.jpg?fit=270%2C270&#038;ssl=1" />
<style type="text/css" id="wp-custom-css">
p { 
font-size:14px; 
} 
iframe {
max-width:100% !important;
}		</style>
<noscript><style> .wpb_animate_when_almost_visible { opacity: 1; }</style></noscript> 
<!-- Respond.js IE8 support of HTML5 elements and media queries -->
<!--[if lt IE 9]>
<script src="https://psxextreme.com/wp-content/themes/psx/js/respond.min.js"></script>
<![endif]-->
</head>
<body class="bp-nouveau post-template-default single single-post postid-48120 single-format-standard custom-background wpb-js-composer js-comp-ver-6.4.1 vc_responsive no-js">
<header>
<nav role="navigation">
<div class="navbar navbar-default">
<div class="pull-right hidden-xs hidden-sm" style="margin-top:20px;"><ul id="" class="cnss-social-icon " style="text-align:right;"><li class="cn-fa-facebook" style="display:inline-block;"><a class="" target="_blank" href="https://www.facebook.com/PSXExtreme/" title="Facebook" style=""><img src="https://psxextreme.com/wp-content/uploads/2020/06/facebook.png" border="0" width="46" height="46" alt="Facebook" title="Facebook" style="margin:2px;" /></a></li><li class="cn-fa-twitter" style="display:inline-block;"><a class="" target="_blank" href="https://www.twitter.com/PSXExtreme" title="Twitter" style=""><img src="https://psxextreme.com/wp-content/uploads/2020/06/twitter.png" border="0" width="46" height="46" alt="Twitter" title="Twitter" style="margin:2px;" /></a></li><li class="cn-fa-forums" style="display:inline-block;"><a class=""  href="https://psxextreme.com/forums/" title="Forums" style=""><img src="https://psxextreme.com/wp-content/uploads/2020/06/forums.png" border="0" width="46" height="46" alt="Forums" title="Forums" style="margin:2px;" /></a></li><li class="cn-fa-discord" style="display:inline-block;"><a class="" target="_blank" href="https://discord.gg/TYAUB7Z" title="discord" style=""><img src="https://psxextreme.com/wp-content/uploads/2020/06/Discord-Logo-White.png" border="0" width="46" height="46" alt="discord" title="discord" style="margin:2px;" /></a></li></ul></div>
<div class="container">
<!-- .navbar-toggle is used as the toggle for collapsed navbar content -->
<div class="navbar-header">
<button type="button" class="navbar-toggle" data-toggle="collapse" data-target=".navbar-responsive-collapse">
<span class="icon-bar"></span>
<span class="icon-bar"></span>
<span class="icon-bar"></span>
</button>
<a class="navbar-brand" href="https://psxextreme.com/" title="PSX Extreme" rel="home">
<img src="https://psxextreme.com/wp-content/uploads/2018/03/logo.png" alt="PSX Extreme" />
</a>
</div>
<div class="navbar-collapse collapse navbar-responsive-collapse">
<ul id="menu-main-menu" class="nav navbar-nav"><li id="menu-item-26503" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-26503"><a href="https://psxextreme.com/">Home</a></li>
<li id="menu-item-31510" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-31510"><a href="https://psxextreme.com/news/">News</a></li>
<li id="menu-item-31519" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-31519"><a href="https://psxextreme.com/reviews/">Reviews</a></li>
<li id="menu-item-31558" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-31558"><a href="https://psxextreme.com/rundown/">Rundown</a></li>
<li id="menu-item-28724" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-28724"><a href="https://psxextreme.com/about-us/">About Us</a></li>
<li id="menu-item-48282" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-48282"><a href="https://psxextreme.com/forums/">Forums</a></li>
</ul>
</div>
</div>
</div>           
</nav>
</header><!-- end of header -->
<div class="container page-c" style="margin: 10px auto;">
<div id="wrapper" class="clearfix">
<div class="row">
<div class="col-xs-12" style="margin-bottom:20px;">		<div class="wizardinfosys_autosearch_wrapper">
<form id="wizardinfosys_autosearch_form" full_search_url="https://psxextreme.com/?s=%q%" action="https://psxextreme.com/" method="get">
<div class="wp_autosearch_form_wrapper" style="max-width: px;">
<label class="wp_autosearch_form_label"></label>
<input name="s" class="wp_autosearch_input" type="text"  value="" style="width: 95%;" placeholder="" autocomplete="off" />
<button style="display: none;" class="wp_autosearch_submit"></button>
</div>
</form>
</div>
</div>
<div class="hidden-xs hidden-sm col-md-3 col-lg-3">    
<aside id="widgets" class="left1">
<div id="nav_menu-12" class="widget-wrapper-left widget_nav_menu"><div class="widget-title">PlayStation 5</div><div class="menu-playstation-5-container"><ul id="menu-playstation-5" class="menu"><li id="menu-item-33455" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33455"><a href="https://psxextreme.com/category/news/ps5/">PS5 News</a></li>
</ul></div></div><div id="nav_menu-2" class="widget-wrapper-left widget_nav_menu"><div class="widget-title">PlayStation 4</div><div class="menu-playstation-4-container"><ul id="menu-playstation-4" class="menu"><li id="menu-item-29860" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29860"><a href="https://psxextreme.com/category/news/ps4/">PS4 News</a></li>
<li id="menu-item-26507" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-26507"><a href="https://psxextreme.com/category/reviews/playstation-4-reviews/">PS4 Reviews</a></li>
<li id="menu-item-26506" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-26506"><a href="https://psxextreme.com/category/reviews/playstation-4-previews/">PS4 Previews</a></li>
</ul></div></div><div id="nav_menu-10" class="widget-wrapper-left widget_nav_menu"><div class="widget-title">PlayStation VR</div><div class="menu-playstation-vr-container"><ul id="menu-playstation-vr" class="menu"><li id="menu-item-29862" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29862"><a href="https://psxextreme.com/category/news/psvr/">PSVR News</a></li>
<li id="menu-item-29864" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29864"><a href="https://psxextreme.com/category/reviews/psvr-reviews/">PSVR Reviews</a></li>
<li id="menu-item-29863" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29863"><a href="https://psxextreme.com/category/reviews/psvr-previews/">PSVR Previews</a></li>
</ul></div></div><div id="nav_menu-3" class="widget-wrapper-left widget_nav_menu"><div class="widget-title">PlayStation 3</div><div class="menu-playstation-3-container"><ul id="menu-playstation-3" class="menu"><li id="menu-item-26508" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-26508"><a href="https://psxextreme.com/category/playstation-3/playstation-3-news/">PS3 News</a></li>
<li id="menu-item-26510" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-26510"><a href="https://psxextreme.com/category/playstation-3/reviews-3/">PS3 Reviews</a></li>
<li id="menu-item-26509" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-26509"><a href="https://psxextreme.com/category/playstation-3/previews/">PS3 Previews</a></li>
</ul></div></div><div id="nav_menu-6" class="widget-wrapper-left widget_nav_menu"><div class="widget-title">PlayStation Vita</div><div class="menu-playstation-vita-container"><ul id="menu-playstation-vita" class="menu"><li id="menu-item-28701" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-28701"><a href="https://psxextreme.com/category/news/vita/">Vita News</a></li>
<li id="menu-item-26588" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-26588"><a href="https://psxextreme.com/category/reviews/playstation-vita-reviews/">Vita Reviews</a></li>
<li id="menu-item-26587" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-26587"><a href="https://psxextreme.com/category/news/playstation-vita/playstation-vita-previews/">Vita Previews</a></li>
</ul></div></div><div id="nav_menu-7" class="widget-wrapper-left widget_nav_menu"><div class="widget-title">Misc</div><div class="menu-about-links-container"><ul id="menu-about-links" class="menu"><li id="menu-item-26593" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-26593"><a href="https://psxextreme.com/about-us/">About Us</a></li>
<li id="menu-item-26599" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-privacy-policy menu-item-26599"><a href="https://psxextreme.com/about-us/privacy-policy/">Privacy Policy</a></li>
<li id="menu-item-31888" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-31888"><a href="https://psxextreme.com/about-us/#contactusmain">Contact Us</a></li>
<li id="menu-item-26601" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-26601"><a href="https://psxextreme.com/advertise/">Advertise on PSXE</a></li>
<li id="menu-item-34339" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-34339"><a href="https://psxextreme.com/about-us/contribute/">Write For PSX Extreme</a></li>
<li id="menu-item-26600" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-26600"><a href="https://psxextreme.com/links/">Links</a></li>
</ul></div></div>
</aside><!-- end of #widgets -->
</div>
<div class="col-xs-12 col-sm-12 col-md-6 col-lg-6" style="border-left:1px solid #ddd;border-right:1px solid #ddd;">
<ul class="breadcrumb"><li><a href="https://psxextreme.com">Home</a></li><li><a href="https://psxextreme.com/category/news/">News</a> <a href="https://psxextreme.com/category/news/feature/">Feature</a> </li> <li class="active">PlayStation 2 20th Anniversary Retrospective</li></ul>
<article id="post-48120" class="post-48120 post type-post status-publish format-standard has-post-thumbnail hentry category-feature category-news tag-20th-anniversary tag-dmc tag-god-of-war tag-gta tag-guitar-hero tag-mgs tag-persona tag-ps2 tag-sony">
<img width="1920" height="1080" src="https://psxextreme.com/wp-content/uploads/2020/10/ps2logo.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image jetpack-lazy-image" alt="" loading="lazy" data-lazy-srcset="https://i2.wp.com/psxextreme.com/wp-content/uploads/2020/10/ps2logo.jpg?w=1920&amp;ssl=1 1920w, https://i2.wp.com/psxextreme.com/wp-content/uploads/2020/10/ps2logo.jpg?resize=300%2C169&amp;ssl=1 300w, https://i2.wp.com/psxextreme.com/wp-content/uploads/2020/10/ps2logo.jpg?resize=1024%2C576&amp;ssl=1 1024w, https://i2.wp.com/psxextreme.com/wp-content/uploads/2020/10/ps2logo.jpg?resize=768%2C432&amp;ssl=1 768w, https://i2.wp.com/psxextreme.com/wp-content/uploads/2020/10/ps2logo.jpg?resize=1536%2C864&amp;ssl=1 1536w, https://i2.wp.com/psxextreme.com/wp-content/uploads/2020/10/ps2logo.jpg?resize=250%2C141&amp;ssl=1 250w, https://i2.wp.com/psxextreme.com/wp-content/uploads/2020/10/ps2logo.jpg?resize=600%2C338&amp;ssl=1 600w, https://i2.wp.com/psxextreme.com/wp-content/uploads/2020/10/ps2logo.jpg?w=1100&amp;ssl=1 1100w, https://i2.wp.com/psxextreme.com/wp-content/uploads/2020/10/ps2logo.jpg?w=1650&amp;ssl=1 1650w" data-lazy-sizes="(max-width: 1920px) 100vw, 1920px" data-lazy-src="https://psxextreme.com/wp-content/uploads/2020/10/ps2logo.jpg?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" />
<header class="page-header">
<h1 class="page-title">PlayStation 2 20th Anniversary Retrospective</h1>
</header>
<section class="post-meta">
<i class="icon-time"></i> <a href="https://psxextreme.com/news/playstation-2-20th-anniversary-retrospective/" title="10:36 pm" rel="bookmark">October 29, 2020</a> <i class="icon-user"></i> <span class="author vcard"><a class="url fn n" href="https://psxextreme.com/author/alex_moretti/" title="View all posts by Alex Moretti">Alex Moretti</a></span>
<span class="comments-link">
<span class="mdash">&mdash;</span>
<a href="https://psxextreme.com/news/playstation-2-20th-anniversary-retrospective/#respond">No Comments <i class="icon-arrow-down"></i></a>
</span>
</section><!-- end of .post-meta -->
<section class="post-entry">
<p>The PlayStation 2, in addition to still reigning supreme as the best-selling gaming console of all time, is one of the most beloved platforms in history. With, arguably, the most dominant lineup of AAA platform-exclusive games ever, the PS2&#8217;s fanbase spreads far and wide, and includes several of our editors right here at PSXExtreme. In celebration of the console&#8217;s 20th anniversary earlier this week, the editors and contributors at PSXE decided to look back through time and reminisce about some of our favorite games from the PS2, and what they meant to us.</p>
<p>If you feel like we missed anything, which may certainly be the case given how many truly excellent games graced the PS2, please let us know in the comments!</p>
<p>&nbsp;</p>
<h2>Christopher D. Anderson (Managing Editor):</h2>
<h2>Silent Hill 2 and 3</h2>
<p><img loading="lazy" class="aligncenter size-full wp-image-48252 jetpack-lazy-image" src="https://i1.wp.com/psxextreme.com/wp-content/uploads/2020/10/Silent-Hill-3.jpg?resize=550%2C309&#038;ssl=1" alt="Silent Hill 3" width="550" height="309" data-recalc-dims="1" data-lazy-srcset="https://i1.wp.com/psxextreme.com/wp-content/uploads/2020/10/Silent-Hill-3.jpg?w=1920&amp;ssl=1 1920w, https://i1.wp.com/psxextreme.com/wp-content/uploads/2020/10/Silent-Hill-3.jpg?resize=300%2C169&amp;ssl=1 300w, https://i1.wp.com/psxextreme.com/wp-content/uploads/2020/10/Silent-Hill-3.jpg?resize=1024%2C576&amp;ssl=1 1024w, https://i1.wp.com/psxextreme.com/wp-content/uploads/2020/10/Silent-Hill-3.jpg?resize=768%2C432&amp;ssl=1 768w, https://i1.wp.com/psxextreme.com/wp-content/uploads/2020/10/Silent-Hill-3.jpg?resize=1536%2C864&amp;ssl=1 1536w, https://i1.wp.com/psxextreme.com/wp-content/uploads/2020/10/Silent-Hill-3.jpg?resize=250%2C141&amp;ssl=1 250w, https://i1.wp.com/psxextreme.com/wp-content/uploads/2020/10/Silent-Hill-3.jpg?resize=600%2C338&amp;ssl=1 600w, https://i1.wp.com/psxextreme.com/wp-content/uploads/2020/10/Silent-Hill-3.jpg?w=1100&amp;ssl=1 1100w, https://i1.wp.com/psxextreme.com/wp-content/uploads/2020/10/Silent-Hill-3.jpg?w=1650&amp;ssl=1 1650w" data-lazy-sizes="(max-width: 550px) 100vw, 550px" data-lazy-src="https://i1.wp.com/psxextreme.com/wp-content/uploads/2020/10/Silent-Hill-3.jpg?resize=550%2C309&amp;is-pending-load=1#038;ssl=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img loading="lazy" class="aligncenter size-full wp-image-48252" src="https://i1.wp.com/psxextreme.com/wp-content/uploads/2020/10/Silent-Hill-3.jpg?resize=550%2C309&#038;ssl=1" alt="Silent Hill 3" width="550" height="309" srcset="https://i1.wp.com/psxextreme.com/wp-content/uploads/2020/10/Silent-Hill-3.jpg?w=1920&amp;ssl=1 1920w, https://i1.wp.com/psxextreme.com/wp-content/uploads/2020/10/Silent-Hill-3.jpg?resize=300%2C169&amp;ssl=1 300w, https://i1.wp.com/psxextreme.com/wp-content/uploads/2020/10/Silent-Hill-3.jpg?resize=1024%2C576&amp;ssl=1 1024w, https://i1.wp.com/psxextreme.com/wp-content/uploads/2020/10/Silent-Hill-3.jpg?resize=768%2C432&amp;ssl=1 768w, https://i1.wp.com/psxextreme.com/wp-content/uploads/2020/10/Silent-Hill-3.jpg?resize=1536%2C864&amp;ssl=1 1536w, https://i1.wp.com/psxextreme.com/wp-content/uploads/2020/10/Silent-Hill-3.jpg?resize=250%2C141&amp;ssl=1 250w, https://i1.wp.com/psxextreme.com/wp-content/uploads/2020/10/Silent-Hill-3.jpg?resize=600%2C338&amp;ssl=1 600w, https://i1.wp.com/psxextreme.com/wp-content/uploads/2020/10/Silent-Hill-3.jpg?w=1100&amp;ssl=1 1100w, https://i1.wp.com/psxextreme.com/wp-content/uploads/2020/10/Silent-Hill-3.jpg?w=1650&amp;ssl=1 1650w" sizes="(max-width: 550px) 100vw, 550px" data-recalc-dims="1" /></noscript></p>
<p>Okay, I might be cheating a little on this one but the Silent Hill series is still my favorite series ever. Even if it does go a bit downhill in later games. And I won’t even get into Silent Hills. The first game blew me away and changed how I think about games and even horror in general. I’ve played them all however and Silent Hill 2 and 3 are some of the best games to date in my opinion. These games reign when it comes to atmosphere and very few games have been able to capture a similar feel.</p>
<h2>Shadow of the Colossus</h2>
<p><img loading="lazy" class="aligncenter size-full wp-image-48253 jetpack-lazy-image" src="https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/Shadow-of-the-Colossus.jpg?resize=550%2C309&#038;ssl=1" alt="Shadow of the Colossus" width="550" height="309" data-recalc-dims="1" data-lazy-srcset="https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/Shadow-of-the-Colossus.jpg?w=1920&amp;ssl=1 1920w, https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/Shadow-of-the-Colossus.jpg?resize=300%2C169&amp;ssl=1 300w, https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/Shadow-of-the-Colossus.jpg?resize=1024%2C576&amp;ssl=1 1024w, https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/Shadow-of-the-Colossus.jpg?resize=768%2C432&amp;ssl=1 768w, https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/Shadow-of-the-Colossus.jpg?resize=1536%2C864&amp;ssl=1 1536w, https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/Shadow-of-the-Colossus.jpg?resize=250%2C141&amp;ssl=1 250w, https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/Shadow-of-the-Colossus.jpg?resize=600%2C338&amp;ssl=1 600w, https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/Shadow-of-the-Colossus.jpg?w=1100&amp;ssl=1 1100w, https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/Shadow-of-the-Colossus.jpg?w=1650&amp;ssl=1 1650w" data-lazy-sizes="(max-width: 550px) 100vw, 550px" data-lazy-src="https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/Shadow-of-the-Colossus.jpg?resize=550%2C309&amp;is-pending-load=1#038;ssl=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img loading="lazy" class="aligncenter size-full wp-image-48253" src="https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/Shadow-of-the-Colossus.jpg?resize=550%2C309&#038;ssl=1" alt="Shadow of the Colossus" width="550" height="309" srcset="https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/Shadow-of-the-Colossus.jpg?w=1920&amp;ssl=1 1920w, https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/Shadow-of-the-Colossus.jpg?resize=300%2C169&amp;ssl=1 300w, https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/Shadow-of-the-Colossus.jpg?resize=1024%2C576&amp;ssl=1 1024w, https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/Shadow-of-the-Colossus.jpg?resize=768%2C432&amp;ssl=1 768w, https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/Shadow-of-the-Colossus.jpg?resize=1536%2C864&amp;ssl=1 1536w, https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/Shadow-of-the-Colossus.jpg?resize=250%2C141&amp;ssl=1 250w, https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/Shadow-of-the-Colossus.jpg?resize=600%2C338&amp;ssl=1 600w, https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/Shadow-of-the-Colossus.jpg?w=1100&amp;ssl=1 1100w, https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/Shadow-of-the-Colossus.jpg?w=1650&amp;ssl=1 1650w" sizes="(max-width: 550px) 100vw, 550px" data-recalc-dims="1" /></noscript></p>
<p>I missed Ico when it came out but I jumped right in with Shadow of the Colossus. I really liked the isolation spotted with epic battles against gigantic beasts. Great open land that begged to be explored and an amazing soundtrack rounded out an amazing experience. I always felt bad about taking the colossus down too. Defeating these giants was satisfying followed immediately by sadness and maybe even a bit of regret. Except that last one. That one was a jerk.</p>
<h2>Devil May Cry 3</h2>
<p><img loading="lazy" class="aligncenter size-full wp-image-48254 jetpack-lazy-image" src="https://i1.wp.com/psxextreme.com/wp-content/uploads/2020/10/Devil-May-Cry-3.jpg?resize=550%2C300&#038;ssl=1" alt="Devil May Cry 3" width="550" height="300" data-recalc-dims="1" data-lazy-srcset="https://i1.wp.com/psxextreme.com/wp-content/uploads/2020/10/Devil-May-Cry-3.jpg?w=1271&amp;ssl=1 1271w, https://i1.wp.com/psxextreme.com/wp-content/uploads/2020/10/Devil-May-Cry-3.jpg?resize=300%2C164&amp;ssl=1 300w, https://i1.wp.com/psxextreme.com/wp-content/uploads/2020/10/Devil-May-Cry-3.jpg?resize=1024%2C558&amp;ssl=1 1024w, https://i1.wp.com/psxextreme.com/wp-content/uploads/2020/10/Devil-May-Cry-3.jpg?resize=768%2C419&amp;ssl=1 768w, https://i1.wp.com/psxextreme.com/wp-content/uploads/2020/10/Devil-May-Cry-3.jpg?resize=250%2C136&amp;ssl=1 250w, https://i1.wp.com/psxextreme.com/wp-content/uploads/2020/10/Devil-May-Cry-3.jpg?resize=600%2C327&amp;ssl=1 600w, https://i1.wp.com/psxextreme.com/wp-content/uploads/2020/10/Devil-May-Cry-3.jpg?w=1100&amp;ssl=1 1100w" data-lazy-sizes="(max-width: 550px) 100vw, 550px" data-lazy-src="https://i1.wp.com/psxextreme.com/wp-content/uploads/2020/10/Devil-May-Cry-3.jpg?resize=550%2C300&amp;is-pending-load=1#038;ssl=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img loading="lazy" class="aligncenter size-full wp-image-48254" src="https://i1.wp.com/psxextreme.com/wp-content/uploads/2020/10/Devil-May-Cry-3.jpg?resize=550%2C300&#038;ssl=1" alt="Devil May Cry 3" width="550" height="300" srcset="https://i1.wp.com/psxextreme.com/wp-content/uploads/2020/10/Devil-May-Cry-3.jpg?w=1271&amp;ssl=1 1271w, https://i1.wp.com/psxextreme.com/wp-content/uploads/2020/10/Devil-May-Cry-3.jpg?resize=300%2C164&amp;ssl=1 300w, https://i1.wp.com/psxextreme.com/wp-content/uploads/2020/10/Devil-May-Cry-3.jpg?resize=1024%2C558&amp;ssl=1 1024w, https://i1.wp.com/psxextreme.com/wp-content/uploads/2020/10/Devil-May-Cry-3.jpg?resize=768%2C419&amp;ssl=1 768w, https://i1.wp.com/psxextreme.com/wp-content/uploads/2020/10/Devil-May-Cry-3.jpg?resize=250%2C136&amp;ssl=1 250w, https://i1.wp.com/psxextreme.com/wp-content/uploads/2020/10/Devil-May-Cry-3.jpg?resize=600%2C327&amp;ssl=1 600w, https://i1.wp.com/psxextreme.com/wp-content/uploads/2020/10/Devil-May-Cry-3.jpg?w=1100&amp;ssl=1 1100w" sizes="(max-width: 550px) 100vw, 550px" data-recalc-dims="1" /></noscript></p>
<p>While I fell in love with this series because of the first game, it was the third one that really did it for me. I thought I was a Devil May Cry expert when I loaded up this game, only to be destroyed in the very first level. But I kept trying. And dying. And trying. And dying. Until I beat it and it was a very satisfying experience because of that. Dante’s attitude and the flashiness of the gameplay is icing on the cake. But the challenge was amazing.</p>
<h2>God of War</h2>
<p><img loading="lazy" class="aligncenter size-full wp-image-48255 jetpack-lazy-image" src="https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/God-of-War.jpg?resize=550%2C309&#038;ssl=1" alt="God of War" width="550" height="309" data-recalc-dims="1" data-lazy-srcset="https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/God-of-War.jpg?w=1920&amp;ssl=1 1920w, https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/God-of-War.jpg?resize=300%2C169&amp;ssl=1 300w, https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/God-of-War.jpg?resize=1024%2C576&amp;ssl=1 1024w, https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/God-of-War.jpg?resize=768%2C432&amp;ssl=1 768w, https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/God-of-War.jpg?resize=1536%2C864&amp;ssl=1 1536w, https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/God-of-War.jpg?resize=250%2C141&amp;ssl=1 250w, https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/God-of-War.jpg?resize=600%2C338&amp;ssl=1 600w, https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/God-of-War.jpg?w=1100&amp;ssl=1 1100w, https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/God-of-War.jpg?w=1650&amp;ssl=1 1650w" data-lazy-sizes="(max-width: 550px) 100vw, 550px" data-lazy-src="https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/God-of-War.jpg?resize=550%2C309&amp;is-pending-load=1#038;ssl=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img loading="lazy" class="aligncenter size-full wp-image-48255" src="https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/God-of-War.jpg?resize=550%2C309&#038;ssl=1" alt="God of War" width="550" height="309" srcset="https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/God-of-War.jpg?w=1920&amp;ssl=1 1920w, https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/God-of-War.jpg?resize=300%2C169&amp;ssl=1 300w, https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/God-of-War.jpg?resize=1024%2C576&amp;ssl=1 1024w, https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/God-of-War.jpg?resize=768%2C432&amp;ssl=1 768w, https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/God-of-War.jpg?resize=1536%2C864&amp;ssl=1 1536w, https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/God-of-War.jpg?resize=250%2C141&amp;ssl=1 250w, https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/God-of-War.jpg?resize=600%2C338&amp;ssl=1 600w, https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/God-of-War.jpg?w=1100&amp;ssl=1 1100w, https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/God-of-War.jpg?w=1650&amp;ssl=1 1650w" sizes="(max-width: 550px) 100vw, 550px" data-recalc-dims="1" /></noscript></p>
<p>Kratos is one angry dude. And maybe I was a little angry in my younger years as well. Set this big angry dude in a Greek setting that includes fighting the gods and monsters from ancient greek mythology and you have a formula for a truly epic game. The action was intense and satisfying and while fairly one dimensional, Kratos was a bit of an antihero. Which for me, at the time, was a novelty. The series has grown a lot since then with the latest offering in some surprising ways. I still pop this one in from time to time.</p>
<h2>Beyond Good and Evil</h2>
<p><img loading="lazy" class="aligncenter size-full wp-image-48256 jetpack-lazy-image" src="https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/Beyond-Good-and-Evil.jpg?resize=550%2C413&#038;ssl=1" alt="Beyond Good and Evil" width="550" height="413" data-recalc-dims="1" data-lazy-srcset="https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/Beyond-Good-and-Evil.jpg?w=1440&amp;ssl=1 1440w, https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/Beyond-Good-and-Evil.jpg?resize=300%2C225&amp;ssl=1 300w, https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/Beyond-Good-and-Evil.jpg?resize=1024%2C768&amp;ssl=1 1024w, https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/Beyond-Good-and-Evil.jpg?resize=768%2C576&amp;ssl=1 768w, https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/Beyond-Good-and-Evil.jpg?resize=250%2C188&amp;ssl=1 250w, https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/Beyond-Good-and-Evil.jpg?resize=533%2C400&amp;ssl=1 533w, https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/Beyond-Good-and-Evil.jpg?w=1100&amp;ssl=1 1100w" data-lazy-sizes="(max-width: 550px) 100vw, 550px" data-lazy-src="https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/Beyond-Good-and-Evil.jpg?resize=550%2C413&amp;is-pending-load=1#038;ssl=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img loading="lazy" class="aligncenter size-full wp-image-48256" src="https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/Beyond-Good-and-Evil.jpg?resize=550%2C413&#038;ssl=1" alt="Beyond Good and Evil" width="550" height="413" srcset="https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/Beyond-Good-and-Evil.jpg?w=1440&amp;ssl=1 1440w, https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/Beyond-Good-and-Evil.jpg?resize=300%2C225&amp;ssl=1 300w, https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/Beyond-Good-and-Evil.jpg?resize=1024%2C768&amp;ssl=1 1024w, https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/Beyond-Good-and-Evil.jpg?resize=768%2C576&amp;ssl=1 768w, https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/Beyond-Good-and-Evil.jpg?resize=250%2C188&amp;ssl=1 250w, https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/Beyond-Good-and-Evil.jpg?resize=533%2C400&amp;ssl=1 533w, https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/Beyond-Good-and-Evil.jpg?w=1100&amp;ssl=1 1100w" sizes="(max-width: 550px) 100vw, 550px" data-recalc-dims="1" /></noscript></p>
<p>This game was one of the first games I played that included a lot of heart. Interesting gameplay and awesome characters made this niche title one of my favorites. I spent a lot of hours taking pictures of hidden animals and exploring the world. This game also had excellent world building. Because of the special place in my heart (and many other gamers) this game has stuck itself firmly in my list of favorite PS2 games and even games in general.</p>
<h2>Kingdom Hearts</h2>
<p><img loading="lazy" class="aligncenter size-full wp-image-48257 jetpack-lazy-image" src="https://i1.wp.com/psxextreme.com/wp-content/uploads/2020/10/Kingdom-Hearts.jpg?resize=550%2C367&#038;ssl=1" alt="Kingdom Hearts" width="550" height="367" data-recalc-dims="1" data-lazy-srcset="https://i1.wp.com/psxextreme.com/wp-content/uploads/2020/10/Kingdom-Hearts.jpg?w=1170&amp;ssl=1 1170w, https://i1.wp.com/psxextreme.com/wp-content/uploads/2020/10/Kingdom-Hearts.jpg?resize=300%2C200&amp;ssl=1 300w, https://i1.wp.com/psxextreme.com/wp-content/uploads/2020/10/Kingdom-Hearts.jpg?resize=1024%2C683&amp;ssl=1 1024w, https://i1.wp.com/psxextreme.com/wp-content/uploads/2020/10/Kingdom-Hearts.jpg?resize=768%2C512&amp;ssl=1 768w, https://i1.wp.com/psxextreme.com/wp-content/uploads/2020/10/Kingdom-Hearts.jpg?resize=250%2C167&amp;ssl=1 250w, https://i1.wp.com/psxextreme.com/wp-content/uploads/2020/10/Kingdom-Hearts.jpg?resize=600%2C400&amp;ssl=1 600w, https://i1.wp.com/psxextreme.com/wp-content/uploads/2020/10/Kingdom-Hearts.jpg?w=1100&amp;ssl=1 1100w" data-lazy-sizes="(max-width: 550px) 100vw, 550px" data-lazy-src="https://i1.wp.com/psxextreme.com/wp-content/uploads/2020/10/Kingdom-Hearts.jpg?resize=550%2C367&amp;is-pending-load=1#038;ssl=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img loading="lazy" class="aligncenter size-full wp-image-48257" src="https://i1.wp.com/psxextreme.com/wp-content/uploads/2020/10/Kingdom-Hearts.jpg?resize=550%2C367&#038;ssl=1" alt="Kingdom Hearts" width="550" height="367" srcset="https://i1.wp.com/psxextreme.com/wp-content/uploads/2020/10/Kingdom-Hearts.jpg?w=1170&amp;ssl=1 1170w, https://i1.wp.com/psxextreme.com/wp-content/uploads/2020/10/Kingdom-Hearts.jpg?resize=300%2C200&amp;ssl=1 300w, https://i1.wp.com/psxextreme.com/wp-content/uploads/2020/10/Kingdom-Hearts.jpg?resize=1024%2C683&amp;ssl=1 1024w, https://i1.wp.com/psxextreme.com/wp-content/uploads/2020/10/Kingdom-Hearts.jpg?resize=768%2C512&amp;ssl=1 768w, https://i1.wp.com/psxextreme.com/wp-content/uploads/2020/10/Kingdom-Hearts.jpg?resize=250%2C167&amp;ssl=1 250w, https://i1.wp.com/psxextreme.com/wp-content/uploads/2020/10/Kingdom-Hearts.jpg?resize=600%2C400&amp;ssl=1 600w, https://i1.wp.com/psxextreme.com/wp-content/uploads/2020/10/Kingdom-Hearts.jpg?w=1100&amp;ssl=1 1100w" sizes="(max-width: 550px) 100vw, 550px" data-recalc-dims="1" /></noscript></p>
<p>We all know how awesome Kingdom Hearts is. The combination of Disney and Square Enix was a surprisingly satisfying experience. Lots of hours exploring and grinding through the story was just the beginning of a pretty wild ride that is this series. Being a great game aside, the main reason this is on my list is because of one particular battle. The secret battle with Sephiroth. This battle was a harrowing challenge and I just would not give up no matter how many times he beat me. To top things off when you finally do defeat him he doesn’t even die per say. He’s just like “Alright, that was fun. Laters.” And vanishes. It’s still one of my greatest gaming accomplishments though.</p>
<p>&nbsp;</p>
<h2>Ryan Hartmann (Senior Editor):</h2>
<h2>Soul Reaver 2</h2>
<p><img loading="lazy" class="alignnone wp-image-48289 size-full jetpack-lazy-image" src="https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/sr2.jpeg?resize=550%2C309&#038;ssl=1" alt width="550" height="309" data-recalc-dims="1" data-lazy-srcset="https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/sr2.jpeg?w=1920&amp;ssl=1 1920w, https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/sr2.jpeg?resize=300%2C169&amp;ssl=1 300w, https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/sr2.jpeg?resize=1024%2C576&amp;ssl=1 1024w, https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/sr2.jpeg?resize=768%2C432&amp;ssl=1 768w, https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/sr2.jpeg?resize=1536%2C864&amp;ssl=1 1536w, https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/sr2.jpeg?resize=250%2C141&amp;ssl=1 250w, https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/sr2.jpeg?resize=600%2C338&amp;ssl=1 600w, https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/sr2.jpeg?w=1100&amp;ssl=1 1100w, https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/sr2.jpeg?w=1650&amp;ssl=1 1650w" data-lazy-sizes="(max-width: 550px) 100vw, 550px" data-lazy-src="https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/sr2.jpeg?resize=550%2C309&amp;is-pending-load=1#038;ssl=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img loading="lazy" class="alignnone wp-image-48289 size-full" src="https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/sr2.jpeg?resize=550%2C309&#038;ssl=1" alt="" width="550" height="309" srcset="https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/sr2.jpeg?w=1920&amp;ssl=1 1920w, https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/sr2.jpeg?resize=300%2C169&amp;ssl=1 300w, https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/sr2.jpeg?resize=1024%2C576&amp;ssl=1 1024w, https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/sr2.jpeg?resize=768%2C432&amp;ssl=1 768w, https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/sr2.jpeg?resize=1536%2C864&amp;ssl=1 1536w, https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/sr2.jpeg?resize=250%2C141&amp;ssl=1 250w, https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/sr2.jpeg?resize=600%2C338&amp;ssl=1 600w, https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/sr2.jpeg?w=1100&amp;ssl=1 1100w, https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/sr2.jpeg?w=1650&amp;ssl=1 1650w" sizes="(max-width: 550px) 100vw, 550px" data-recalc-dims="1" /></noscript></p>
<p>The Legacy of Kain is both one of my favorite franchises in gaming history, and one of the most disappointing. Always wonderfully written and directed, the franchise peaked once Amy Hennig (who would later go on to write and direct the first three Uncharted games) took the helm as lead writer and creative director, and Soul Reaver 2 was the apex of a series loaded with atmosphere and overflowing with ideas and unrealized potential. Sadly, 2003&#8217;s follow-up, Defiance, was mostly a disappointment that ended on something of a cliffhanger, and the state of the franchise&#8217;s licensing rights makes any future sequels or reboots highly unlikely, denying fans such as myself any reasonable expectation of closure any time soon.</p>
<h2>Final Fantasy XII</h2>
<p><img loading="lazy" class="alignnone wp-image-48286 size-full jetpack-lazy-image" src="https://i2.wp.com/psxextreme.com/wp-content/uploads/2020/10/ff12.jpg?resize=550%2C309&#038;ssl=1" alt width="550" height="309" data-recalc-dims="1" data-lazy-srcset="https://i2.wp.com/psxextreme.com/wp-content/uploads/2020/10/ff12.jpg?w=1920&amp;ssl=1 1920w, https://i2.wp.com/psxextreme.com/wp-content/uploads/2020/10/ff12.jpg?resize=300%2C169&amp;ssl=1 300w, https://i2.wp.com/psxextreme.com/wp-content/uploads/2020/10/ff12.jpg?resize=1024%2C576&amp;ssl=1 1024w, https://i2.wp.com/psxextreme.com/wp-content/uploads/2020/10/ff12.jpg?resize=768%2C432&amp;ssl=1 768w, https://i2.wp.com/psxextreme.com/wp-content/uploads/2020/10/ff12.jpg?resize=1536%2C864&amp;ssl=1 1536w, https://i2.wp.com/psxextreme.com/wp-content/uploads/2020/10/ff12.jpg?resize=250%2C141&amp;ssl=1 250w, https://i2.wp.com/psxextreme.com/wp-content/uploads/2020/10/ff12.jpg?resize=600%2C338&amp;ssl=1 600w, https://i2.wp.com/psxextreme.com/wp-content/uploads/2020/10/ff12.jpg?w=1100&amp;ssl=1 1100w, https://i2.wp.com/psxextreme.com/wp-content/uploads/2020/10/ff12.jpg?w=1650&amp;ssl=1 1650w" data-lazy-sizes="(max-width: 550px) 100vw, 550px" data-lazy-src="https://i2.wp.com/psxextreme.com/wp-content/uploads/2020/10/ff12.jpg?resize=550%2C309&amp;is-pending-load=1#038;ssl=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img loading="lazy" class="alignnone wp-image-48286 size-full" src="https://i2.wp.com/psxextreme.com/wp-content/uploads/2020/10/ff12.jpg?resize=550%2C309&#038;ssl=1" alt="" width="550" height="309" srcset="https://i2.wp.com/psxextreme.com/wp-content/uploads/2020/10/ff12.jpg?w=1920&amp;ssl=1 1920w, https://i2.wp.com/psxextreme.com/wp-content/uploads/2020/10/ff12.jpg?resize=300%2C169&amp;ssl=1 300w, https://i2.wp.com/psxextreme.com/wp-content/uploads/2020/10/ff12.jpg?resize=1024%2C576&amp;ssl=1 1024w, https://i2.wp.com/psxextreme.com/wp-content/uploads/2020/10/ff12.jpg?resize=768%2C432&amp;ssl=1 768w, https://i2.wp.com/psxextreme.com/wp-content/uploads/2020/10/ff12.jpg?resize=1536%2C864&amp;ssl=1 1536w, https://i2.wp.com/psxextreme.com/wp-content/uploads/2020/10/ff12.jpg?resize=250%2C141&amp;ssl=1 250w, https://i2.wp.com/psxextreme.com/wp-content/uploads/2020/10/ff12.jpg?resize=600%2C338&amp;ssl=1 600w, https://i2.wp.com/psxextreme.com/wp-content/uploads/2020/10/ff12.jpg?w=1100&amp;ssl=1 1100w, https://i2.wp.com/psxextreme.com/wp-content/uploads/2020/10/ff12.jpg?w=1650&amp;ssl=1 1650w" sizes="(max-width: 550px) 100vw, 550px" data-recalc-dims="1" /></noscript></p>
<p>I have an odd habit of absolutely hating games that I later come to consider among my favorite of all time, and it&#8217;s something that happens frequently enough that it&#8217;s not mere statistical noise when it happens. Deus Ex: Human Revolution, Mirror&#8217;s Edge, X-COM Enemy Unknown and many others fit this pattern, perhaps none more closely than Final Fantasy XII. A huge Final Fantasy fan at this point and eagerly awaiting a non-MMO follow up to the amazing Final Fantasy X, the macro-management and tactical focus of XII threw me so hard that I shelved the game after just 15 hours, content to never play it again. Eventually I was prodded into giving the game a second chance, and over the subsequent 15 years the game has become not only my favorite installment in Final Fantasy, but my favorite JRPG of all time. It&#8217;s still a shame that Square-Enix literally focus-tested Vaan and Penelo into the game, derailing what would have been a much better-balanced story following the original ensemble cast of Balthier, Fran, Basch and Ashe, but with a little patience and effort the game&#8217;s tactical nature truly begins to shine and creates a JRPG experience unlike anything else, except perhaps its inspirational cousin, Final Fantasy Tactics.</p>
<h2>Resident Evil 4</h2>
<p><img loading="lazy" class="alignnone wp-image-48285 size-full jetpack-lazy-image" src="https://i1.wp.com/psxextreme.com/wp-content/uploads/2020/10/RE4-HD-Screenshot-05.jpg?resize=550%2C306&#038;ssl=1" alt width="550" height="306" data-recalc-dims="1" data-lazy-srcset="https://i1.wp.com/psxextreme.com/wp-content/uploads/2020/10/RE4-HD-Screenshot-05.jpg?w=1920&amp;ssl=1 1920w, https://i1.wp.com/psxextreme.com/wp-content/uploads/2020/10/RE4-HD-Screenshot-05.jpg?resize=300%2C167&amp;ssl=1 300w, https://i1.wp.com/psxextreme.com/wp-content/uploads/2020/10/RE4-HD-Screenshot-05.jpg?resize=1024%2C570&amp;ssl=1 1024w, https://i1.wp.com/psxextreme.com/wp-content/uploads/2020/10/RE4-HD-Screenshot-05.jpg?resize=768%2C427&amp;ssl=1 768w, https://i1.wp.com/psxextreme.com/wp-content/uploads/2020/10/RE4-HD-Screenshot-05.jpg?resize=1536%2C854&amp;ssl=1 1536w, https://i1.wp.com/psxextreme.com/wp-content/uploads/2020/10/RE4-HD-Screenshot-05.jpg?resize=250%2C139&amp;ssl=1 250w, https://i1.wp.com/psxextreme.com/wp-content/uploads/2020/10/RE4-HD-Screenshot-05.jpg?resize=600%2C334&amp;ssl=1 600w, https://i1.wp.com/psxextreme.com/wp-content/uploads/2020/10/RE4-HD-Screenshot-05.jpg?w=1100&amp;ssl=1 1100w, https://i1.wp.com/psxextreme.com/wp-content/uploads/2020/10/RE4-HD-Screenshot-05.jpg?w=1650&amp;ssl=1 1650w" data-lazy-sizes="(max-width: 550px) 100vw, 550px" data-lazy-src="https://i1.wp.com/psxextreme.com/wp-content/uploads/2020/10/RE4-HD-Screenshot-05.jpg?resize=550%2C306&amp;is-pending-load=1#038;ssl=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img loading="lazy" class="alignnone wp-image-48285 size-full" src="https://i1.wp.com/psxextreme.com/wp-content/uploads/2020/10/RE4-HD-Screenshot-05.jpg?resize=550%2C306&#038;ssl=1" alt="" width="550" height="306" srcset="https://i1.wp.com/psxextreme.com/wp-content/uploads/2020/10/RE4-HD-Screenshot-05.jpg?w=1920&amp;ssl=1 1920w, https://i1.wp.com/psxextreme.com/wp-content/uploads/2020/10/RE4-HD-Screenshot-05.jpg?resize=300%2C167&amp;ssl=1 300w, https://i1.wp.com/psxextreme.com/wp-content/uploads/2020/10/RE4-HD-Screenshot-05.jpg?resize=1024%2C570&amp;ssl=1 1024w, https://i1.wp.com/psxextreme.com/wp-content/uploads/2020/10/RE4-HD-Screenshot-05.jpg?resize=768%2C427&amp;ssl=1 768w, https://i1.wp.com/psxextreme.com/wp-content/uploads/2020/10/RE4-HD-Screenshot-05.jpg?resize=1536%2C854&amp;ssl=1 1536w, https://i1.wp.com/psxextreme.com/wp-content/uploads/2020/10/RE4-HD-Screenshot-05.jpg?resize=250%2C139&amp;ssl=1 250w, https://i1.wp.com/psxextreme.com/wp-content/uploads/2020/10/RE4-HD-Screenshot-05.jpg?resize=600%2C334&amp;ssl=1 600w, https://i1.wp.com/psxextreme.com/wp-content/uploads/2020/10/RE4-HD-Screenshot-05.jpg?w=1100&amp;ssl=1 1100w, https://i1.wp.com/psxextreme.com/wp-content/uploads/2020/10/RE4-HD-Screenshot-05.jpg?w=1650&amp;ssl=1 1650w" sizes="(max-width: 550px) 100vw, 550px" data-recalc-dims="1" /></noscript></p>
<p>I have a confession; I am one of &#8220;those people&#8221;. You know who I&#8217;m talking about, the ones who hated Resident Evil and relentlessly mocked the franchise&#8217;s absurd nature at every turn. The hamfisted tank controls, the ridiculously amateurish voice acting, sophomoric writing&#8230; it was all just a little too damn silly for me. At least, that is, until I played Resident Evil 4. With a revamped (but now still horrendously obsolete) movement system, greater focus on action and cinematic production values and a story that leaned into its absurd nature with subtle winks to the audience, RE4 was truly a rebirth for the franchise. Of course, that&#8217;s also why so many diehard, original fans hate it, but given its importance in the direction of the recent remakes of Resident Evil 2 and 3, I&#8217;d have to argue that this game deserves the accolades it&#8217;s received over the years.</p>
<h2>Zone of the Enders: The Second Runner</h2>
<p><img loading="lazy" class="alignnone wp-image-48287 size-full jetpack-lazy-image" src="https://i2.wp.com/psxextreme.com/wp-content/uploads/2020/10/20200702104919_1.jpg?resize=550%2C309&#038;ssl=1" alt width="550" height="309" data-recalc-dims="1" data-lazy-srcset="https://i2.wp.com/psxextreme.com/wp-content/uploads/2020/10/20200702104919_1.jpg?w=1920&amp;ssl=1 1920w, https://i2.wp.com/psxextreme.com/wp-content/uploads/2020/10/20200702104919_1.jpg?resize=300%2C169&amp;ssl=1 300w, https://i2.wp.com/psxextreme.com/wp-content/uploads/2020/10/20200702104919_1.jpg?resize=1024%2C576&amp;ssl=1 1024w, https://i2.wp.com/psxextreme.com/wp-content/uploads/2020/10/20200702104919_1.jpg?resize=768%2C432&amp;ssl=1 768w, https://i2.wp.com/psxextreme.com/wp-content/uploads/2020/10/20200702104919_1.jpg?resize=1536%2C864&amp;ssl=1 1536w, https://i2.wp.com/psxextreme.com/wp-content/uploads/2020/10/20200702104919_1.jpg?resize=250%2C141&amp;ssl=1 250w, https://i2.wp.com/psxextreme.com/wp-content/uploads/2020/10/20200702104919_1.jpg?resize=600%2C338&amp;ssl=1 600w, https://i2.wp.com/psxextreme.com/wp-content/uploads/2020/10/20200702104919_1.jpg?w=1100&amp;ssl=1 1100w, https://i2.wp.com/psxextreme.com/wp-content/uploads/2020/10/20200702104919_1.jpg?w=1650&amp;ssl=1 1650w" data-lazy-sizes="(max-width: 550px) 100vw, 550px" data-lazy-src="https://i2.wp.com/psxextreme.com/wp-content/uploads/2020/10/20200702104919_1.jpg?resize=550%2C309&amp;is-pending-load=1#038;ssl=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img loading="lazy" class="alignnone wp-image-48287 size-full" src="https://i2.wp.com/psxextreme.com/wp-content/uploads/2020/10/20200702104919_1.jpg?resize=550%2C309&#038;ssl=1" alt="" width="550" height="309" srcset="https://i2.wp.com/psxextreme.com/wp-content/uploads/2020/10/20200702104919_1.jpg?w=1920&amp;ssl=1 1920w, https://i2.wp.com/psxextreme.com/wp-content/uploads/2020/10/20200702104919_1.jpg?resize=300%2C169&amp;ssl=1 300w, https://i2.wp.com/psxextreme.com/wp-content/uploads/2020/10/20200702104919_1.jpg?resize=1024%2C576&amp;ssl=1 1024w, https://i2.wp.com/psxextreme.com/wp-content/uploads/2020/10/20200702104919_1.jpg?resize=768%2C432&amp;ssl=1 768w, https://i2.wp.com/psxextreme.com/wp-content/uploads/2020/10/20200702104919_1.jpg?resize=1536%2C864&amp;ssl=1 1536w, https://i2.wp.com/psxextreme.com/wp-content/uploads/2020/10/20200702104919_1.jpg?resize=250%2C141&amp;ssl=1 250w, https://i2.wp.com/psxextreme.com/wp-content/uploads/2020/10/20200702104919_1.jpg?resize=600%2C338&amp;ssl=1 600w, https://i2.wp.com/psxextreme.com/wp-content/uploads/2020/10/20200702104919_1.jpg?w=1100&amp;ssl=1 1100w, https://i2.wp.com/psxextreme.com/wp-content/uploads/2020/10/20200702104919_1.jpg?w=1650&amp;ssl=1 1650w" sizes="(max-width: 550px) 100vw, 550px" data-recalc-dims="1" /></noscript></p>
<p>I will be the first to admit that I am a huge fan of Hideo Kojima, perhaps even to a point of irrationality, but that&#8217;s just the inevitable byproduct of the man delivering, over the course of 35 years, games that feel like they were custom-tailored for me. Zone of the Enders is the best possible example of this, as I&#8217;d always loved the style and allure of the huge mechs in Japanese media, but absolutely hated the clunky, slow, janky gameplay that accompanied most games in that genre. Suddenly, here is Kojima with the world&#8217;s first &#8220;High Speed Robot Action&#8221; game, one where these massive mechs were as fast as greased lightning, as devastatingly powerful as they were fun to pilot. While the first installment was little more than proof of concept (and a great way to push the demo for Metal Gear Solid 2, at the time the most anticipated game in history), Second Runner got a much more personal touch from Kojima, with a deeper story that played well with the anime trappings of the production values.</p>
<h2>Metal Gear Solid 2: Sons of Liberty</h2>
<p><img loading="lazy" class="alignnone wp-image-48288 size-full jetpack-lazy-image" src="https://i2.wp.com/psxextreme.com/wp-content/uploads/2020/10/mgs2.jpg?resize=550%2C309&#038;ssl=1" alt width="550" height="309" data-recalc-dims="1" data-lazy-srcset="https://i2.wp.com/psxextreme.com/wp-content/uploads/2020/10/mgs2.jpg?w=1920&amp;ssl=1 1920w, https://i2.wp.com/psxextreme.com/wp-content/uploads/2020/10/mgs2.jpg?resize=300%2C169&amp;ssl=1 300w, https://i2.wp.com/psxextreme.com/wp-content/uploads/2020/10/mgs2.jpg?resize=1024%2C576&amp;ssl=1 1024w, https://i2.wp.com/psxextreme.com/wp-content/uploads/2020/10/mgs2.jpg?resize=768%2C432&amp;ssl=1 768w, https://i2.wp.com/psxextreme.com/wp-content/uploads/2020/10/mgs2.jpg?resize=1536%2C864&amp;ssl=1 1536w, https://i2.wp.com/psxextreme.com/wp-content/uploads/2020/10/mgs2.jpg?resize=250%2C141&amp;ssl=1 250w, https://i2.wp.com/psxextreme.com/wp-content/uploads/2020/10/mgs2.jpg?resize=600%2C338&amp;ssl=1 600w, https://i2.wp.com/psxextreme.com/wp-content/uploads/2020/10/mgs2.jpg?w=1100&amp;ssl=1 1100w, https://i2.wp.com/psxextreme.com/wp-content/uploads/2020/10/mgs2.jpg?w=1650&amp;ssl=1 1650w" data-lazy-sizes="(max-width: 550px) 100vw, 550px" data-lazy-src="https://i2.wp.com/psxextreme.com/wp-content/uploads/2020/10/mgs2.jpg?resize=550%2C309&amp;is-pending-load=1#038;ssl=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img loading="lazy" class="alignnone wp-image-48288 size-full" src="https://i2.wp.com/psxextreme.com/wp-content/uploads/2020/10/mgs2.jpg?resize=550%2C309&#038;ssl=1" alt="" width="550" height="309" srcset="https://i2.wp.com/psxextreme.com/wp-content/uploads/2020/10/mgs2.jpg?w=1920&amp;ssl=1 1920w, https://i2.wp.com/psxextreme.com/wp-content/uploads/2020/10/mgs2.jpg?resize=300%2C169&amp;ssl=1 300w, https://i2.wp.com/psxextreme.com/wp-content/uploads/2020/10/mgs2.jpg?resize=1024%2C576&amp;ssl=1 1024w, https://i2.wp.com/psxextreme.com/wp-content/uploads/2020/10/mgs2.jpg?resize=768%2C432&amp;ssl=1 768w, https://i2.wp.com/psxextreme.com/wp-content/uploads/2020/10/mgs2.jpg?resize=1536%2C864&amp;ssl=1 1536w, https://i2.wp.com/psxextreme.com/wp-content/uploads/2020/10/mgs2.jpg?resize=250%2C141&amp;ssl=1 250w, https://i2.wp.com/psxextreme.com/wp-content/uploads/2020/10/mgs2.jpg?resize=600%2C338&amp;ssl=1 600w, https://i2.wp.com/psxextreme.com/wp-content/uploads/2020/10/mgs2.jpg?w=1100&amp;ssl=1 1100w, https://i2.wp.com/psxextreme.com/wp-content/uploads/2020/10/mgs2.jpg?w=1650&amp;ssl=1 1650w" sizes="(max-width: 550px) 100vw, 550px" data-recalc-dims="1" /></noscript></p>
<p>It&#8217;s kind of weird to look back at all the criticism that Metal Gear Solid 2 received from dissenters upon its release in 2001, given that most of it centered around how ludicrous its plot was, how impossibly stupid it was to suggest that governments would try to control the masses with directed electronic information disinformation, spyware, privacy intrusions and, most laughable of all, the concept that we would ever turn over our nuclear arsenal to an artificial intelligence.</p>
<p>Except now, in 2020, the game looks downright prescient, given that our government has either announced, or been exposed for doing, all of these things. Yes, including trying to <a href="https://www.military.com/daily-news/2020/09/29/congress-wants-manhattan-project-military-artificial-intelligence.html">turn over our nuclear weapons programs to an AI</a>.</p>
<p>More importantly, though, Metal Gear Solid 2 became the first truly killer exclusive app for the PS2, one that showcased all the horsepower the system could muster to create a game that, in terms of production quality, visual fidelity, and attention to detail, stood head and shoulders above the rest of the pack for years. A gorgeous game with flawless stealth action gameplay, and a story that feels more like a documentary than science fiction these days, but you know what my all-time favorite thing about this game was? Shooting buckets of ice and watching the water melt in real time:</p>
<p><iframe title="Metal Gear Solid 2 HD - MELTING ICE | MGS2 ICE | WHOA TECHNOLOGY (WOAH)" width="550" height="309" src="https://www.youtube.com/embed/o2WdpOOGMaY?feature=oembed" frameborder="0" allow="accelerometer; autoplay; clipboard-write; encrypted-media; gyroscope; picture-in-picture" allowfullscreen></iframe></p>
<p>&nbsp;</p>
<h2>Alex Moretti (Contributor):</h2>
<h2><span data-preserver-spaces="true">Yu-Gi-Oh: Duelists Of The Roses</span></h2>
<p><img loading="lazy" class="alignnone wp-image-48291 size-full jetpack-lazy-image" src="https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/yugi.jpg?resize=550%2C309&#038;ssl=1" alt width="550" height="309" data-recalc-dims="1" data-lazy-srcset="https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/yugi.jpg?w=1280&amp;ssl=1 1280w, https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/yugi.jpg?resize=300%2C169&amp;ssl=1 300w, https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/yugi.jpg?resize=1024%2C576&amp;ssl=1 1024w, https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/yugi.jpg?resize=768%2C432&amp;ssl=1 768w, https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/yugi.jpg?resize=250%2C141&amp;ssl=1 250w, https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/yugi.jpg?resize=600%2C338&amp;ssl=1 600w, https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/yugi.jpg?w=1100&amp;ssl=1 1100w" data-lazy-sizes="(max-width: 550px) 100vw, 550px" data-lazy-src="https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/yugi.jpg?resize=550%2C309&amp;is-pending-load=1#038;ssl=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img loading="lazy" class="alignnone wp-image-48291 size-full" src="https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/yugi.jpg?resize=550%2C309&#038;ssl=1" alt="" width="550" height="309" srcset="https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/yugi.jpg?w=1280&amp;ssl=1 1280w, https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/yugi.jpg?resize=300%2C169&amp;ssl=1 300w, https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/yugi.jpg?resize=1024%2C576&amp;ssl=1 1024w, https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/yugi.jpg?resize=768%2C432&amp;ssl=1 768w, https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/yugi.jpg?resize=250%2C141&amp;ssl=1 250w, https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/yugi.jpg?resize=600%2C338&amp;ssl=1 600w, https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/yugi.jpg?w=1100&amp;ssl=1 1100w" sizes="(max-width: 550px) 100vw, 550px" data-recalc-dims="1" /></noscript></p>
<p><span data-preserver-spaces="true">While most games in the Yu-Gi-Oh series are only aimed towards seasoned veterans, Duelists Of The Roses was a fun, unique spin-off title that re-imagined Yu-Gi-Oh&#8217;s cast as 16th-century icons who have recruited you to fight with them, either on the side of the Lancastrians or the Yorkists.</span></p>
<p><span data-preserver-spaces="true">It was an incredibly fun strategy game with a lot of passion put into it. </span><span data-preserver-spaces="true">If only we got more unique games like this from Konami nowadays.</span></p>
<h2><span data-preserver-spaces="true">Monster Rancher 4</span></h2>
<p><img loading="lazy" class="alignnone wp-image-48292 size-full jetpack-lazy-image" src="https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/mr4.jpg?resize=550%2C309&#038;ssl=1" alt width="550" height="309" data-recalc-dims="1" data-lazy-srcset="https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/mr4.jpg?w=1920&amp;ssl=1 1920w, https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/mr4.jpg?resize=300%2C169&amp;ssl=1 300w, https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/mr4.jpg?resize=1024%2C576&amp;ssl=1 1024w, https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/mr4.jpg?resize=768%2C432&amp;ssl=1 768w, https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/mr4.jpg?resize=1536%2C864&amp;ssl=1 1536w, https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/mr4.jpg?resize=250%2C141&amp;ssl=1 250w, https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/mr4.jpg?resize=600%2C338&amp;ssl=1 600w, https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/mr4.jpg?w=1100&amp;ssl=1 1100w, https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/mr4.jpg?w=1650&amp;ssl=1 1650w" data-lazy-sizes="(max-width: 550px) 100vw, 550px" data-lazy-src="https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/mr4.jpg?resize=550%2C309&amp;is-pending-load=1#038;ssl=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img loading="lazy" class="alignnone wp-image-48292 size-full" src="https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/mr4.jpg?resize=550%2C309&#038;ssl=1" alt="" width="550" height="309" srcset="https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/mr4.jpg?w=1920&amp;ssl=1 1920w, https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/mr4.jpg?resize=300%2C169&amp;ssl=1 300w, https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/mr4.jpg?resize=1024%2C576&amp;ssl=1 1024w, https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/mr4.jpg?resize=768%2C432&amp;ssl=1 768w, https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/mr4.jpg?resize=1536%2C864&amp;ssl=1 1536w, https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/mr4.jpg?resize=250%2C141&amp;ssl=1 250w, https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/mr4.jpg?resize=600%2C338&amp;ssl=1 600w, https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/mr4.jpg?w=1100&amp;ssl=1 1100w, https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/mr4.jpg?w=1650&amp;ssl=1 1650w" sizes="(max-width: 550px) 100vw, 550px" data-recalc-dims="1" /></noscript></p>
<p><span data-preserver-spaces="true">I remember this game for having a unique mechanic exclusive to the Playstation 2. </span><span data-preserver-spaces="true">This simulation game was all about raising monsters, and one of its features was letting you go to a shrine, swapping out the PS2 disc with an audio CD, and watching as a new monster is randomly generated from the said shrine. I spent hours testing out all sorts of different CDs just trying to get the best monsters.</span></p>
<p><span data-preserver-spaces="true">It&#8217;s a shame that we haven&#8217;t gotten a new game in this series since 2010.</span></p>
<h2><span data-preserver-spaces="true">Persona 4</span></h2>
<p><img loading="lazy" class="alignnone wp-image-48294 size-full jetpack-lazy-image" src="https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/p4.jpg?resize=550%2C309&#038;ssl=1" alt width="550" height="309" data-recalc-dims="1" data-lazy-srcset="https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/p4.jpg?w=1920&amp;ssl=1 1920w, https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/p4.jpg?resize=300%2C169&amp;ssl=1 300w, https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/p4.jpg?resize=1024%2C576&amp;ssl=1 1024w, https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/p4.jpg?resize=768%2C432&amp;ssl=1 768w, https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/p4.jpg?resize=1536%2C864&amp;ssl=1 1536w, https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/p4.jpg?resize=250%2C141&amp;ssl=1 250w, https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/p4.jpg?resize=600%2C338&amp;ssl=1 600w, https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/p4.jpg?w=1100&amp;ssl=1 1100w, https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/p4.jpg?w=1650&amp;ssl=1 1650w" data-lazy-sizes="(max-width: 550px) 100vw, 550px" data-lazy-src="https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/p4.jpg?resize=550%2C309&amp;is-pending-load=1#038;ssl=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img loading="lazy" class="alignnone wp-image-48294 size-full" src="https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/p4.jpg?resize=550%2C309&#038;ssl=1" alt="" width="550" height="309" srcset="https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/p4.jpg?w=1920&amp;ssl=1 1920w, https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/p4.jpg?resize=300%2C169&amp;ssl=1 300w, https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/p4.jpg?resize=1024%2C576&amp;ssl=1 1024w, https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/p4.jpg?resize=768%2C432&amp;ssl=1 768w, https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/p4.jpg?resize=1536%2C864&amp;ssl=1 1536w, https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/p4.jpg?resize=250%2C141&amp;ssl=1 250w, https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/p4.jpg?resize=600%2C338&amp;ssl=1 600w, https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/p4.jpg?w=1100&amp;ssl=1 1100w, https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/p4.jpg?w=1650&amp;ssl=1 1650w" sizes="(max-width: 550px) 100vw, 550px" data-recalc-dims="1" /></noscript></p>
<p><span data-preserver-spaces="true">With over 300 hours on record, Persona 4 is my most played game on the PS2. The PS Vita version, Persona 4: Golden has also recently been ported to Steam. </span><span data-preserver-spaces="true">While not as dark as previous entries, this title helped establish Atlus as a prominent developer in the JRPG space.</span></p>
<h2><span data-preserver-spaces="true">Metal Gear Solid 3: Subsistence</span></h2>
<p><img loading="lazy" class="alignnone wp-image-48295 size-full jetpack-lazy-image" src="https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/mgs3.png?resize=550%2C309&#038;ssl=1" alt width="550" height="309" data-recalc-dims="1" data-lazy-srcset="https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/mgs3.png?w=1920&amp;ssl=1 1920w, https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/mgs3.png?resize=300%2C169&amp;ssl=1 300w, https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/mgs3.png?resize=1024%2C576&amp;ssl=1 1024w, https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/mgs3.png?resize=768%2C432&amp;ssl=1 768w, https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/mgs3.png?resize=1536%2C864&amp;ssl=1 1536w, https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/mgs3.png?resize=250%2C141&amp;ssl=1 250w, https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/mgs3.png?resize=600%2C338&amp;ssl=1 600w, https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/mgs3.png?w=1100&amp;ssl=1 1100w, https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/mgs3.png?w=1650&amp;ssl=1 1650w" data-lazy-sizes="(max-width: 550px) 100vw, 550px" data-lazy-src="https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/mgs3.png?resize=550%2C309&amp;is-pending-load=1#038;ssl=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img loading="lazy" class="alignnone wp-image-48295 size-full" src="https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/mgs3.png?resize=550%2C309&#038;ssl=1" alt="" width="550" height="309" srcset="https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/mgs3.png?w=1920&amp;ssl=1 1920w, https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/mgs3.png?resize=300%2C169&amp;ssl=1 300w, https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/mgs3.png?resize=1024%2C576&amp;ssl=1 1024w, https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/mgs3.png?resize=768%2C432&amp;ssl=1 768w, https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/mgs3.png?resize=1536%2C864&amp;ssl=1 1536w, https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/mgs3.png?resize=250%2C141&amp;ssl=1 250w, https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/mgs3.png?resize=600%2C338&amp;ssl=1 600w, https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/mgs3.png?w=1100&amp;ssl=1 1100w, https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/mgs3.png?w=1650&amp;ssl=1 1650w" sizes="(max-width: 550px) 100vw, 550px" data-recalc-dims="1" /></noscript></p>
<p><span data-preserver-spaces="true">Hideo Kojima&#8217;s Metal Gear Solid 3 was already a fantastic game. Subsistence added to it dozens of hours worth of bonus missions, and the debut of Metal Gear Online, giving gamers one of the best value propositions of all time. With a deep camouflage system and a unique health system that rewards patience and exploration, not to mention a narrative more laser-focused than previous entries but still every bit as emotionally powerful, there is just so much to love about this game.</span></p>
<h2>Xenosaga Episode I: Der Wille zur Macht</h2>
<p><img loading="lazy" class="alignnone wp-image-48296 size-full jetpack-lazy-image" src="https://i2.wp.com/psxextreme.com/wp-content/uploads/2020/10/xeno.jpg?resize=550%2C309&#038;ssl=1" alt width="550" height="309" data-recalc-dims="1" data-lazy-srcset="https://i2.wp.com/psxextreme.com/wp-content/uploads/2020/10/xeno.jpg?w=1920&amp;ssl=1 1920w, https://i2.wp.com/psxextreme.com/wp-content/uploads/2020/10/xeno.jpg?resize=300%2C169&amp;ssl=1 300w, https://i2.wp.com/psxextreme.com/wp-content/uploads/2020/10/xeno.jpg?resize=1024%2C576&amp;ssl=1 1024w, https://i2.wp.com/psxextreme.com/wp-content/uploads/2020/10/xeno.jpg?resize=768%2C432&amp;ssl=1 768w, https://i2.wp.com/psxextreme.com/wp-content/uploads/2020/10/xeno.jpg?resize=1536%2C864&amp;ssl=1 1536w, https://i2.wp.com/psxextreme.com/wp-content/uploads/2020/10/xeno.jpg?resize=250%2C141&amp;ssl=1 250w, https://i2.wp.com/psxextreme.com/wp-content/uploads/2020/10/xeno.jpg?resize=600%2C338&amp;ssl=1 600w, https://i2.wp.com/psxextreme.com/wp-content/uploads/2020/10/xeno.jpg?w=1100&amp;ssl=1 1100w, https://i2.wp.com/psxextreme.com/wp-content/uploads/2020/10/xeno.jpg?w=1650&amp;ssl=1 1650w" data-lazy-sizes="(max-width: 550px) 100vw, 550px" data-lazy-src="https://i2.wp.com/psxextreme.com/wp-content/uploads/2020/10/xeno.jpg?resize=550%2C309&amp;is-pending-load=1#038;ssl=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img loading="lazy" class="alignnone wp-image-48296 size-full" src="https://i2.wp.com/psxextreme.com/wp-content/uploads/2020/10/xeno.jpg?resize=550%2C309&#038;ssl=1" alt="" width="550" height="309" srcset="https://i2.wp.com/psxextreme.com/wp-content/uploads/2020/10/xeno.jpg?w=1920&amp;ssl=1 1920w, https://i2.wp.com/psxextreme.com/wp-content/uploads/2020/10/xeno.jpg?resize=300%2C169&amp;ssl=1 300w, https://i2.wp.com/psxextreme.com/wp-content/uploads/2020/10/xeno.jpg?resize=1024%2C576&amp;ssl=1 1024w, https://i2.wp.com/psxextreme.com/wp-content/uploads/2020/10/xeno.jpg?resize=768%2C432&amp;ssl=1 768w, https://i2.wp.com/psxextreme.com/wp-content/uploads/2020/10/xeno.jpg?resize=1536%2C864&amp;ssl=1 1536w, https://i2.wp.com/psxextreme.com/wp-content/uploads/2020/10/xeno.jpg?resize=250%2C141&amp;ssl=1 250w, https://i2.wp.com/psxextreme.com/wp-content/uploads/2020/10/xeno.jpg?resize=600%2C338&amp;ssl=1 600w, https://i2.wp.com/psxextreme.com/wp-content/uploads/2020/10/xeno.jpg?w=1100&amp;ssl=1 1100w, https://i2.wp.com/psxextreme.com/wp-content/uploads/2020/10/xeno.jpg?w=1650&amp;ssl=1 1650w" sizes="(max-width: 550px) 100vw, 550px" data-recalc-dims="1" /></noscript></p>
<p><span data-preserver-spaces="true">As a fan of both anime and space operas, this game offered everything I could want in a turn-based RPG. </span><span data-preserver-spaces="true">Epic Boss fights and set pieces, fantastic character introductions, and great setups with deserved payoffs. Over 80 hours of story, and over 130 hours for completionists, with so much extra content to unlock, the only real way to experience this game is to play it for yourself.</span></p>
<p>&nbsp;</p>
<h2>Tyler Harvey (Editor-in-Chief):</h2>
<h2>Grand Theft Auto: San Andreas</h2>
<p><img loading="lazy" class="alignnone wp-image-48305 size-full jetpack-lazy-image" src="https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/000000000000000.jpg?resize=550%2C309&#038;ssl=1" alt width="550" height="309" data-recalc-dims="1" data-lazy-srcset="https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/000000000000000.jpg?w=1920&amp;ssl=1 1920w, https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/000000000000000.jpg?resize=300%2C169&amp;ssl=1 300w, https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/000000000000000.jpg?resize=1024%2C576&amp;ssl=1 1024w, https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/000000000000000.jpg?resize=768%2C432&amp;ssl=1 768w, https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/000000000000000.jpg?resize=1536%2C864&amp;ssl=1 1536w, https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/000000000000000.jpg?resize=250%2C141&amp;ssl=1 250w, https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/000000000000000.jpg?resize=600%2C338&amp;ssl=1 600w, https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/000000000000000.jpg?w=1100&amp;ssl=1 1100w, https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/000000000000000.jpg?w=1650&amp;ssl=1 1650w" data-lazy-sizes="(max-width: 550px) 100vw, 550px" data-lazy-src="https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/000000000000000.jpg?resize=550%2C309&amp;is-pending-load=1#038;ssl=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img loading="lazy" class="alignnone wp-image-48305 size-full" src="https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/000000000000000.jpg?resize=550%2C309&#038;ssl=1" alt="" width="550" height="309" srcset="https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/000000000000000.jpg?w=1920&amp;ssl=1 1920w, https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/000000000000000.jpg?resize=300%2C169&amp;ssl=1 300w, https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/000000000000000.jpg?resize=1024%2C576&amp;ssl=1 1024w, https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/000000000000000.jpg?resize=768%2C432&amp;ssl=1 768w, https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/000000000000000.jpg?resize=1536%2C864&amp;ssl=1 1536w, https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/000000000000000.jpg?resize=250%2C141&amp;ssl=1 250w, https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/000000000000000.jpg?resize=600%2C338&amp;ssl=1 600w, https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/000000000000000.jpg?w=1100&amp;ssl=1 1100w, https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/000000000000000.jpg?w=1650&amp;ssl=1 1650w" sizes="(max-width: 550px) 100vw, 550px" data-recalc-dims="1" /></noscript></p>
<p>To say that I&#8217;m a GTA fan, or a fan of Rockstar in general, would be a pretty big understatement. Not only do I own every GTA ever made, I own multiple copies of them. And yet, despite having three copies of GTA 5, the one game I always find myself going back to is GTA San Andreas. I have such fond memories of SA, with my most memorable being a tad odd. I was sitting in front of my fathers 53&#8243; plasma TV, when a commercial for San Andreas came on. Welcome To The Jungle blasted. It was such a magical moment. One I&#8217;ll never forget.</p>
<h2>Guitar Hero</h2>
<p><img loading="lazy" class="alignnone wp-image-48306 size-full jetpack-lazy-image" src="https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/0000000000000000000000.jpg?resize=550%2C309&#038;ssl=1" alt width="550" height="309" data-recalc-dims="1" data-lazy-srcset="https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/0000000000000000000000.jpg?w=1920&amp;ssl=1 1920w, https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/0000000000000000000000.jpg?resize=300%2C169&amp;ssl=1 300w, https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/0000000000000000000000.jpg?resize=1024%2C576&amp;ssl=1 1024w, https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/0000000000000000000000.jpg?resize=768%2C432&amp;ssl=1 768w, https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/0000000000000000000000.jpg?resize=1536%2C864&amp;ssl=1 1536w, https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/0000000000000000000000.jpg?resize=250%2C141&amp;ssl=1 250w, https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/0000000000000000000000.jpg?resize=600%2C338&amp;ssl=1 600w, https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/0000000000000000000000.jpg?w=1100&amp;ssl=1 1100w, https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/0000000000000000000000.jpg?w=1650&amp;ssl=1 1650w" data-lazy-sizes="(max-width: 550px) 100vw, 550px" data-lazy-src="https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/0000000000000000000000.jpg?resize=550%2C309&amp;is-pending-load=1#038;ssl=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img loading="lazy" class="alignnone wp-image-48306 size-full" src="https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/0000000000000000000000.jpg?resize=550%2C309&#038;ssl=1" alt="" width="550" height="309" srcset="https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/0000000000000000000000.jpg?w=1920&amp;ssl=1 1920w, https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/0000000000000000000000.jpg?resize=300%2C169&amp;ssl=1 300w, https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/0000000000000000000000.jpg?resize=1024%2C576&amp;ssl=1 1024w, https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/0000000000000000000000.jpg?resize=768%2C432&amp;ssl=1 768w, https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/0000000000000000000000.jpg?resize=1536%2C864&amp;ssl=1 1536w, https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/0000000000000000000000.jpg?resize=250%2C141&amp;ssl=1 250w, https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/0000000000000000000000.jpg?resize=600%2C338&amp;ssl=1 600w, https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/0000000000000000000000.jpg?w=1100&amp;ssl=1 1100w, https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/10/0000000000000000000000.jpg?w=1650&amp;ssl=1 1650w" sizes="(max-width: 550px) 100vw, 550px" data-recalc-dims="1" /></noscript></p>
<p>Oh boy, Guitar Hero. I know most people likely think of Guitar Hero, and imagine the PS3 or Xbox 360. And sure, it definitely reached its height on those consoles, but it all started on the PS2. That&#8217;s where I got my first taste of the plastic guitar. Shredding in the living room with friends. Trying to get the highest score possible. I&#8217;d usually win, of course.</p>
<p>This list could have gone on forever, and nearly did before editing began and we were forced to make some tough choices on what to include and what to leave out. So what games did we miss? Lots! Shout out in the comments and let us know what your favorite PS2 games were and why!</p>
<p>&nbsp;</p>
<p>&nbsp;</p>
<div id='jp-relatedposts' class='jp-relatedposts' >
<h3 class="jp-relatedposts-headline"><em>Related</em></h3>
</div>
</section><!-- end of .post-entry -->
<footer class="article-footer">
<div class="post-data">
Tagged with: <a class="btn btn-mini btn-default" href="https://psxextreme.com/tag/20th-anniversary/" rel="tag">20th anniversary</a> <a class="btn btn-mini btn-default" href="https://psxextreme.com/tag/dmc/" rel="tag">dmc</a> <a class="btn btn-mini btn-default" href="https://psxextreme.com/tag/god-of-war/" rel="tag">god of war</a> <a class="btn btn-mini btn-default" href="https://psxextreme.com/tag/gta/" rel="tag">gta</a> <a class="btn btn-mini btn-default" href="https://psxextreme.com/tag/guitar-hero/" rel="tag">guitar hero</a> <a class="btn btn-mini btn-default" href="https://psxextreme.com/tag/mgs/" rel="tag">mgs</a> <a class="btn btn-mini btn-default" href="https://psxextreme.com/tag/persona/" rel="tag">Persona</a> <a class="btn btn-mini btn-default" href="https://psxextreme.com/tag/ps2/" rel="tag">ps2</a> <a class="btn btn-mini btn-default" href="https://psxextreme.com/tag/sony/" rel="tag">sony</a><br />  
</div><!-- end of .post-data --> 
<div class="post-edit"></div>  
</footer>           
</article><!-- end of #post-48120 -->
<div class="wpdiscuz_top_clearing"></div>
<div id='comments' class='comments-area'><div id='respond' style='width: 0;height: 0;clear: both;margin: 0;padding: 0;'></div>    <div id="wpdcom" class="wpdiscuz_unauth wpd-default wpd-layout-1 wpd-comments-open">
<div class="wc_social_plugin_wrapper">
</div>
<div class="wpd-form-wrap">
<div class="wpd-form-head">
<div class="wpd-sbs-toggle">
<i class="far fa-envelope"></i> <span class="wpd-sbs-title">Subscribe</span> <i class="fas fa-caret-down"></i>
</div>
<div class="wpd-auth">
<div class="wpd-login">
<a rel="nofollow" href="https://psxextreme.com/wp-login.php?redirect_to=https%3A%2F%2Fpsxextreme.com%2Fnews%2Fplaystation-2-20th-anniversary-retrospective%2F"><i class='fas fa-sign-in-alt'></i> Login</a>                        </div>
</div>
</div>
<div class="wpdiscuz-subscribe-bar wpdiscuz-hidden">
<form action="https://psxextreme.com/wp-admin/admin-ajax.php?action=wpdAddSubscription" method="post" id="wpdiscuz-subscribe-form">
<div class="wpdiscuz-subscribe-form-intro">Notify of </div>
<div class="wpdiscuz-subscribe-form-option" style="width:40%;">
<select class="wpdiscuz_select" name="wpdiscuzSubscriptionType" >
<option value="post">new follow-up comments</option>
<option value="all_comment" >new replies to my comments</option>
</select>
</div>
<div class="wpdiscuz-item wpdiscuz-subscribe-form-email">
<input  class="email" type="email" name="wpdiscuzSubscriptionEmail" required="required" value="" placeholder="Email"/>
</div>
<div class="wpdiscuz-subscribe-form-button">
<input id="wpdiscuz_subscription_button" class="wpd-prim-button" type="submit" value="&rsaquo;" name="wpdiscuz_subscription_button" />
</div> 
<input type="hidden" id="wpdiscuz_subscribe_form_nonce" name="wpdiscuz_subscribe_form_nonce" value="82717ae101" /><input type="hidden" name="_wp_http_referer" value="/news/playstation-2-20th-anniversary-retrospective/" />                            </form>
</div>
<div class="wpd-form wpd-form-wrapper wpd-main-form-wrapper" id='wpd-main-form-wrapper-0_0'>
</div>
<div id="wpdiscuz_hidden_secondary_form" style="display: none;">
<div class="wpd-form wpd-form-wrapper wpd-secondary-form-wrapper" id='wpd-secondary-form-wrapper-wpdiscuzuniqueid' style='display: none;'>
<div class="wpd-secondary-forms-social-content"></div><div class="clearfix"></div>
</div>
</div>
<div class="wpd-login-to-comment">Please login to comment</div>
</div>
<div id="wpd-threads" class="wpd-thread-wrapper">
<div class="wpd-thread-head">
<div class="wpd-thread-info ">
<span class='wpdtc'>0</span> Comments                </div>
<div class="wpd-space"></div>
<div class="wpd-thread-filter">
<div class="wpd-filter wpdf-reacted wpd_not_clicked" wpd-tooltip="Most reacted comment"><i class="fas fa-bolt"></i></div>
<div class="wpd-filter wpdf-hottest wpd_not_clicked" wpd-tooltip="Hottest comment thread"><i class="fas fa-fire"></i></div>
</div>
</div>
<div class="wpd-comment-info-bar">
<div class="wpd-current-view"><i class="fas fa-quote-left"></i> Inline Feedbacks</div>
<div class="wpd-filter-view-all">View all comments</div>
</div>
<div class="wpd-thread-list">
<div class="wpdiscuz-comment-pagination">
</div>
</div>
</div>
</div>
</div>
<div id="wpdiscuz-loading-bar" class="wpdiscuz-loading-bar-unauth"></div>
<div id="wpdiscuz-comment-message" class="wpdiscuz-comment-message-unauth"></div>
</div>
<div class="hidden-md hidden-lg col-xs-12 col-sm-12">      
<aside id="widgets" class="left1">
<div id="nav_menu-13" class="widget-wrapper-left widget_nav_menu"><div class="widget-title">PS5</div><div class="menu-playstation-5-container"><ul id="menu-playstation-6" class="menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33455"><a href="https://psxextreme.com/category/news/ps5/">PS5 News</a></li>
</ul></div></div><div id="nav_menu-4" class="widget-wrapper-left widget_nav_menu"><div class="widget-title">PS4</div><div class="menu-playstation-4-container"><ul id="menu-playstation-7" class="menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29860"><a href="https://psxextreme.com/category/news/ps4/">PS4 News</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-26507"><a href="https://psxextreme.com/category/reviews/playstation-4-reviews/">PS4 Reviews</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-26506"><a href="https://psxextreme.com/category/reviews/playstation-4-previews/">PS4 Previews</a></li>
</ul></div></div><div id="nav_menu-5" class="widget-wrapper-left widget_nav_menu"><div class="widget-title">PS3</div><div class="menu-playstation-3-container"><ul id="menu-playstation-8" class="menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-26508"><a href="https://psxextreme.com/category/playstation-3/playstation-3-news/">PS3 News</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-26510"><a href="https://psxextreme.com/category/playstation-3/reviews-3/">PS3 Reviews</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-26509"><a href="https://psxextreme.com/category/playstation-3/previews/">PS3 Previews</a></li>
</ul></div></div><div id="nav_menu-8" class="widget-wrapper-left widget_nav_menu"><div class="widget-title">Vita</div><div class="menu-playstation-vita-container"><ul id="menu-playstation-vita-1" class="menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-28701"><a href="https://psxextreme.com/category/news/vita/">Vita News</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-26588"><a href="https://psxextreme.com/category/reviews/playstation-vita-reviews/">Vita Reviews</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-26587"><a href="https://psxextreme.com/category/news/playstation-vita/playstation-vita-previews/">Vita Previews</a></li>
</ul></div></div><div id="nav_menu-9" class="widget-wrapper-left widget_nav_menu"><div class="widget-title">Misc</div><div class="menu-about-links-container"><ul id="menu-about-links-1" class="menu"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-26593"><a href="https://psxextreme.com/about-us/">About Us</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-privacy-policy menu-item-26599"><a href="https://psxextreme.com/about-us/privacy-policy/">Privacy Policy</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-31888"><a href="https://psxextreme.com/about-us/#contactusmain">Contact Us</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-26601"><a href="https://psxextreme.com/advertise/">Advertise on PSXE</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-34339"><a href="https://psxextreme.com/about-us/contribute/">Write For PSX Extreme</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-26600"><a href="https://psxextreme.com/links/">Links</a></li>
</ul></div></div>
</aside><!-- end of #widgets --></div>
<div class="col-xs-12 col-sm-12 col-md-3 col-lg-3">
<aside id="widgets">
<div id="bp_core_login_widget-5" class="widget-wrapper widget_bp_core_login_widget buddypress widget"><div class="widget-title">PSXE Account</div>
<form name="bp-login-form" id="bp-login-widget-form" class="standard-form" action="https://psxextreme.com/wp-login.php" method="post">
<label for="bp-login-widget-user-login">Username</label>
<input type="text" name="log" id="bp-login-widget-user-login" class="input" value="" />
<label for="bp-login-widget-user-pass">Password</label>
<input type="password" name="pwd" id="bp-login-widget-user-pass" class="input" value=""  spellcheck="false" autocomplete="off" />
<div class="forgetmenot"><label for="bp-login-widget-rememberme"><input name="rememberme" type="checkbox" id="bp-login-widget-rememberme" value="forever" /> Remember Me</label></div>
<input type="submit" name="wp-submit" id="bp-login-widget-submit" value="Log In" />
<span class="bp-login-widget-register-link"><a href="https://psxextreme.com/register/">Register</a></span>
</form>
</div><div id="text-2" class="widget-wrapper widget_text">			<div class="textwidget">
<div id="bsa-modern-4" class="bsaProContainerNew bsaProContainer-5 bsa-modern-4 bsa-pro-col-1" style="display: block !important"><div class="bsaProItems bsaGridGutter " style="background-color:"><div class="bsaProItem bsaReset" data-animation="none" style="opacity:1"><a class="bsaProItem__url" rel="nofollow noopener noreferrer" href="https://psxextreme.com/advertise/manage/?sid=5&bsa_pro_id=4&bsa_pro_url=1" target="_blank"><div class="bsaProItemInner" style="background-color:"><div class="bsaProItemInner__copy bsaProItemInner__copyTitle"><div class="bsaProItemInner__copyInner" style="background-color:"><h3 class="bsaProItemInner__title" style="color:">PSXE Official Discord!</h3></div></div><div class="bsaProItemInner__thumbContainer"><div class="bsaProItemInner__thumb"><div class="bsaProItemInner__img" style="background-image: url(&#39;https://psxextreme.com/wp-content/uploads/bfi_thumb/1578730523-Discord-Logo-Black-opsyuu2jt24gq9oab29gf9t0l9lrvpeerqh4ux67l4.png&#39;)"></div></div></div><div class="bsaProItemInner__copy bsaProItemInner__copyDesc"><div class="bsaProItemInner__copyInner"><p class="bsaProItemInner__desc" style="color:">Come talk on the official PSX Extreme Discord server! </p></div></div></div></a></div></div></div>						<script>
(function ($) {
var bsaProContainer = $('.bsaProContainer-5');
var number_show_ads = "0";
var number_hide_ads = "0";
if ( number_show_ads > 0 ) {
setTimeout(function () { bsaProContainer.fadeIn(); }, number_show_ads * 1000);
}
if ( number_hide_ads > 0 ) {
setTimeout(function () { bsaProContainer.fadeOut(); }, number_hide_ads * 1000);
}
})(jQuery);
</script>
</div>
</div><div id="polls-widget-2" class="widget-wrapper widget_polls-widget"><div class="widget-title">Poll</div><div id="polls-14" class="wp-polls">
<form id="polls_form_14" class="wp-polls-form" action="/index.php" method="post">
<p style="display: none;"><input type="hidden" id="poll_14_nonce" name="wp-polls-nonce" value="7106415b49" /></p>
<p style="display: none;"><input type="hidden" name="poll_id" value="14" /></p>
<p style="text-align: center;"><strong>What was your first ever PlayStation?</strong></p><div id="polls-14-ans" class="wp-polls-ans"><ul class="wp-polls-ul">
<li><input type="radio" id="poll-answer-79" name="poll_14" value="79" /> <label for="poll-answer-79">PlayStation (first one)</label></li>
<li><input type="radio" id="poll-answer-80" name="poll_14" value="80" /> <label for="poll-answer-80">PlayStation 2</label></li>
<li><input type="radio" id="poll-answer-81" name="poll_14" value="81" /> <label for="poll-answer-81">PlayStation 3</label></li>
<li><input type="radio" id="poll-answer-82" name="poll_14" value="82" /> <label for="poll-answer-82">PlayStation 4</label></li>
<li><input type="radio" id="poll-answer-83" name="poll_14" value="83" /> <label for="poll-answer-83">PlayStation 5 will be my first ever PlayStation</label></li>
<li><input type="radio" id="poll-answer-84" name="poll_14" value="84" /> <label for="poll-answer-84">PlayStation Portable</label></li>
<li><input type="radio" id="poll-answer-85" name="poll_14" value="85" /> <label for="poll-answer-85">PlayStation Vita</label></li>
</ul><p style="text-align: center;"><input type="button" name="vote" value="   Vote   " class="Buttons" onclick="poll_vote(14);" /></p><p style="text-align: center;"><a href="#ViewPollResults" onclick="poll_result(14); return false;" title="View Results Of This Poll">View Results</a></p></div>
</form>
</div>
<div id="polls-14-loading" class="wp-polls-loading"><img src="https://psxextreme.com/wp-content/plugins/wp-polls/images/loading.gif" width="16" height="16" alt="Loading ..." title="Loading ..." class="wp-polls-image" />&nbsp;Loading ...</div>
<ul><li><a href="https://temp.psxextreme.com/pollsarchive">Polls Archive</a></li></ul></div><div id="newsletterwidgetminimal-2" class="widget-wrapper widget_newsletterwidgetminimal"><div class="widget-title">Newsletter</div><div class="tnp tnp-widget-minimal"><form class="tnp-form" action="https://psxextreme.com/?na=s" method="post"><input type="hidden" name="nr" value="widget-minimal"/><input class="tnp-email" type="email" required name="ne" value="" placeholder="Email"><input class="tnp-submit" type="submit" value="Subscribe"></form></div></div><div id="custom_html-2" class="widget_text widget-wrapper widget_custom_html"><div class="textwidget custom-html-widget"><script async src=" https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js "></script>
<!-- Responsive -->
<ins class="adsbygoogle"
style="display:block"
data-ad-client="ca-pub-7825016775655768"
data-ad-slot="1531652602"
data-ad-format="auto"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div></div><div id="category-posts-4" class="widget-wrapper cat-post-widget"><div class="widget-title">LATEST REVIEWS</div><ul id="category-posts-4-internal" class="category-posts-internal">
<li class='cat-post-item'><a class="cat-post-everything-is-link" href="https://psxextreme.com/reviews/crash-bandicoot-4-its-about-time-review/" title=""><div><span class="cat-post-thumbnail cat-post-scale"><span class="cat-post-crop cat-post-format cat-post-format-standard"><img width="40" height="40" src="https://i1.wp.com/psxextreme.com/wp-content/uploads/2020/10/20201010222224-scaled.jpg?fit=40%2C40&amp;ssl=1" class="attachment-40x40 size-40x40 wp-post-image jetpack-lazy-image" alt="Crash Bandicoot 4 Featured" loading="lazy" data-lazy-srcset="https://i1.wp.com/psxextreme.com/wp-content/uploads/2020/10/20201010222224-scaled.jpg?resize=150%2C150&amp;ssl=1 150w, https://i1.wp.com/psxextreme.com/wp-content/uploads/2020/10/20201010222224-scaled.jpg?resize=50%2C50&amp;ssl=1 50w" data-lazy-sizes="(max-width: 40px) 100vw, 40px" data-lazy-src="https://i1.wp.com/psxextreme.com/wp-content/uploads/2020/10/20201010222224-scaled.jpg?fit=40%2C40&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /></span></span><span class="cat-post-title">Crash Bandicoot 4: It&#8217;s About Time Review</span></div></a></li><li class='cat-post-item'><a class="cat-post-everything-is-link" href="https://psxextreme.com/reviews/ghost-of-tsushima-review/" title=""><div><span class="cat-post-thumbnail cat-post-scale"><span class="cat-post-crop cat-post-format cat-post-format-standard"><img width="40" height="40" src="https://i1.wp.com/psxextreme.com/wp-content/uploads/2020/09/1098390-scaled.jpg?fit=40%2C40&amp;ssl=1" class="attachment-40x40 size-40x40 wp-post-image jetpack-lazy-image" alt="" loading="lazy" data-lazy-srcset="https://i1.wp.com/psxextreme.com/wp-content/uploads/2020/09/1098390-scaled.jpg?resize=150%2C150&amp;ssl=1 150w, https://i1.wp.com/psxextreme.com/wp-content/uploads/2020/09/1098390-scaled.jpg?resize=50%2C50&amp;ssl=1 50w" data-lazy-sizes="(max-width: 40px) 100vw, 40px" data-lazy-src="https://i1.wp.com/psxextreme.com/wp-content/uploads/2020/09/1098390-scaled.jpg?fit=40%2C40&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /></span></span><span class="cat-post-title">Ghost Of Tsushima Review</span></div></a></li><li class='cat-post-item'><a class="cat-post-everything-is-link" href="https://psxextreme.com/reviews/nba-2k21-review/" title=""><div><span class="cat-post-thumbnail cat-post-scale"><span class="cat-post-crop cat-post-format cat-post-format-standard"><img width="40" height="40" src="https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/09/20200911153419-scaled.jpg?fit=40%2C40&amp;ssl=1" class="attachment-40x40 size-40x40 wp-post-image jetpack-lazy-image" alt="NBA 2k21 Featured Image" loading="lazy" data-lazy-srcset="https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/09/20200911153419-scaled.jpg?resize=150%2C150&amp;ssl=1 150w, https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/09/20200911153419-scaled.jpg?resize=50%2C50&amp;ssl=1 50w" data-lazy-sizes="(max-width: 40px) 100vw, 40px" data-lazy-src="https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/09/20200911153419-scaled.jpg?fit=40%2C40&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /></span></span><span class="cat-post-title">NBA 2K21 Review</span></div></a></li><li class='cat-post-item'><a class="cat-post-everything-is-link" href="https://psxextreme.com/reviews/shing-review/" title=""><div><span class="cat-post-thumbnail cat-post-scale"><span class="cat-post-crop cat-post-format cat-post-format-standard"><img width="40" height="40" src="https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/09/Shing_20200903180320-scaled.jpg?fit=40%2C40&amp;ssl=1" class="attachment-40x40 size-40x40 wp-post-image jetpack-lazy-image" alt="Shing! Featured Image" loading="lazy" data-lazy-srcset="https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/09/Shing_20200903180320-scaled.jpg?resize=150%2C150&amp;ssl=1 150w, https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/09/Shing_20200903180320-scaled.jpg?resize=50%2C50&amp;ssl=1 50w" data-lazy-sizes="(max-width: 40px) 100vw, 40px" data-lazy-src="https://i0.wp.com/psxextreme.com/wp-content/uploads/2020/09/Shing_20200903180320-scaled.jpg?fit=40%2C40&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /></span></span><span class="cat-post-title">Shing! Review</span></div></a></li><li class='cat-post-item'><a class="cat-post-everything-is-link" href="https://psxextreme.com/reviews/rocket-arena-review/" title=""><div><span class="cat-post-thumbnail cat-post-scale"><span class="cat-post-crop cat-post-format cat-post-format-standard"><img width="40" height="40" src="https://i2.wp.com/psxextreme.com/wp-content/uploads/2020/07/Rocket-Arena_20200718001051-scaled.jpg?fit=40%2C40&amp;ssl=1" class="attachment-40x40 size-40x40 wp-post-image jetpack-lazy-image" alt="" loading="lazy" data-lazy-srcset="https://i2.wp.com/psxextreme.com/wp-content/uploads/2020/07/Rocket-Arena_20200718001051-scaled.jpg?resize=150%2C150&amp;ssl=1 150w, https://i2.wp.com/psxextreme.com/wp-content/uploads/2020/07/Rocket-Arena_20200718001051-scaled.jpg?resize=50%2C50&amp;ssl=1 50w" data-lazy-sizes="(max-width: 40px) 100vw, 40px" data-lazy-src="https://i2.wp.com/psxextreme.com/wp-content/uploads/2020/07/Rocket-Arena_20200718001051-scaled.jpg?fit=40%2C40&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /></span></span><span class="cat-post-title">Rocket Arena Review</span></div></a></li><li class='cat-post-item'><a class="cat-post-everything-is-link" href="https://psxextreme.com/reviews/the-last-of-us-part-ii-review/" title=""><div><span class="cat-post-thumbnail cat-post-scale"><span class="cat-post-crop cat-post-format cat-post-format-standard"><img width="40" height="40" src="https://i2.wp.com/psxextreme.com/wp-content/uploads/2020/07/ar6zu.jpg?fit=40%2C40&amp;ssl=1" class="attachment-40x40 size-40x40 wp-post-image jetpack-lazy-image" alt="The Last of Us Part II" loading="lazy" data-lazy-srcset="https://i2.wp.com/psxextreme.com/wp-content/uploads/2020/07/ar6zu.jpg?resize=150%2C150&amp;ssl=1 150w, https://i2.wp.com/psxextreme.com/wp-content/uploads/2020/07/ar6zu.jpg?resize=50%2C50&amp;ssl=1 50w" data-lazy-sizes="(max-width: 40px) 100vw, 40px" data-lazy-src="https://i2.wp.com/psxextreme.com/wp-content/uploads/2020/07/ar6zu.jpg?fit=40%2C40&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /></span></span><span class="cat-post-title">The Last Of Us Part II Review</span></div></a></li><li class='cat-post-item'><a class="cat-post-everything-is-link" href="https://psxextreme.com/reviews/valkyria-chronicles-4-review/" title=""><div><span class="cat-post-thumbnail cat-post-scale"><span class="cat-post-crop cat-post-format cat-post-format-standard"><img width="40" height="40" src="https://i2.wp.com/psxextreme.com/wp-content/uploads/2020/06/valkyria-chronicles-4-Box-Art.jpg?fit=40%2C40&amp;ssl=1" class="attachment-40x40 size-40x40 wp-post-image jetpack-lazy-image" alt="Valkyria Chronicles 4" loading="lazy" data-lazy-srcset="https://i2.wp.com/psxextreme.com/wp-content/uploads/2020/06/valkyria-chronicles-4-Box-Art.jpg?resize=150%2C150&amp;ssl=1 150w, https://i2.wp.com/psxextreme.com/wp-content/uploads/2020/06/valkyria-chronicles-4-Box-Art.jpg?resize=50%2C50&amp;ssl=1 50w" data-lazy-sizes="(max-width: 40px) 100vw, 40px" data-lazy-src="https://i2.wp.com/psxextreme.com/wp-content/uploads/2020/06/valkyria-chronicles-4-Box-Art.jpg?fit=40%2C40&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /></span></span><span class="cat-post-title">Valkyria Chronicles 4 Review</span></div></a></li><li class='cat-post-item'><a class="cat-post-everything-is-link" href="https://psxextreme.com/reviews/shenmue-iii-review/" title=""><div><span class="cat-post-thumbnail cat-post-scale"><span class="cat-post-crop cat-post-format cat-post-format-standard"><img width="40" height="40" src="https://i2.wp.com/psxextreme.com/wp-content/uploads/2020/05/rrpp50isnxj97d76lk2t.jpeg?fit=40%2C40&amp;ssl=1" class="attachment-40x40 size-40x40 wp-post-image jetpack-lazy-image" alt="Shenmue III" loading="lazy" data-lazy-srcset="https://i2.wp.com/psxextreme.com/wp-content/uploads/2020/05/rrpp50isnxj97d76lk2t.jpeg?resize=150%2C150&amp;ssl=1 150w, https://i2.wp.com/psxextreme.com/wp-content/uploads/2020/05/rrpp50isnxj97d76lk2t.jpeg?resize=50%2C50&amp;ssl=1 50w" data-lazy-sizes="(max-width: 40px) 100vw, 40px" data-lazy-src="https://i2.wp.com/psxextreme.com/wp-content/uploads/2020/05/rrpp50isnxj97d76lk2t.jpeg?fit=40%2C40&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /></span></span><span class="cat-post-title">Shenmue III Review</span></div></a></li></ul>
</div>
</aside><!-- end of #widgets -->
</div>  

</div>
</div><!-- end of wrapper-->
</div><!-- end of container -->
<div id="footer" class="clearfix">
<div class="container">
<div class="container">
<div class="row">
<div id="widgets" class="home-widgets">
<div class="row">
<div class="col-md-4">
<div id="category-posts-2" class="cat-post-widget"><div id="widget-title-one" class="widget-title-home"><h3>Latest News</h3></div><ul id="category-posts-2-internal" class="category-posts-internal">
<li class='cat-post-item cat-post-current'><a class="cat-post-everything-is-link" href="https://psxextreme.com/news/playstation-2-20th-anniversary-retrospective/" title=""><div><span class="cat-post-title">PlayStation 2 20th Anniversary Retrospective</span></div></a></li><li class='cat-post-item'><a class="cat-post-everything-is-link" href="https://psxextreme.com/news/call-of-duty-black-ops-cold-war-launch-trailer-goes-live-early/" title=""><div><span class="cat-post-title">Call Of Duty: Black Ops Cold War Launch Trailer Goes Live Early</span></div></a></li><li class='cat-post-item'><a class="cat-post-everything-is-link" href="https://psxextreme.com/news/cyberpunk-2077-once-again-delayed/" title=""><div><span class="cat-post-title">Cyberpunk 2077 Once Again Delayed&#8230;</span></div></a></li><li class='cat-post-item'><a class="cat-post-everything-is-link" href="https://psxextreme.com/news/feature/top-game-franchises-that-should-make-a-triumphant-return-on-ps5/" title=""><div><span class="cat-post-title">Top Game Franchises That Should Make A Triumphant Return On PS5</span></div></a></li></ul>
</div>
</div><!-- end of .col-lg-4 -->
<div class="col-md-4">
<div id="category-posts-3" class="cat-post-widget"><div id="widget-title-two" class="widget-title-home"><h3>Latest Reviews</h3></div><ul id="category-posts-3-internal" class="category-posts-internal">
<li class='cat-post-item'><a class="cat-post-everything-is-link" href="https://psxextreme.com/reviews/crash-bandicoot-4-its-about-time-review/" title=""><div><span class="cat-post-title">Crash Bandicoot 4: It&#8217;s About Time Review</span></div></a></li><li class='cat-post-item'><a class="cat-post-everything-is-link" href="https://psxextreme.com/reviews/ghost-of-tsushima-review/" title=""><div><span class="cat-post-title">Ghost Of Tsushima Review</span></div></a></li><li class='cat-post-item'><a class="cat-post-everything-is-link" href="https://psxextreme.com/reviews/nba-2k21-review/" title=""><div><span class="cat-post-title">NBA 2K21 Review</span></div></a></li><li class='cat-post-item'><a class="cat-post-everything-is-link" href="https://psxextreme.com/reviews/shing-review/" title=""><div><span class="cat-post-title">Shing! Review</span></div></a></li></ul>
</div>            
</div><!-- end of .col-lg-4 -->
<div class="col-md-4">
<div id="cnss_widget-2" class="widget_cnss_widget"><ul id="" class="cnss-social-icon " style="text-align:center;"><li class="cn-fa-facebook" style="display:inline-block;"><a class="" target="_blank" href="https://www.facebook.com/PSXExtreme/" title="Facebook" style=""><img src="https://psxextreme.com/wp-content/uploads/2020/06/facebook.png" border="0" width="46" height="46" alt="Facebook" title="Facebook" style="margin:2px;" /></a></li><li class="cn-fa-twitter" style="display:inline-block;"><a class="" target="_blank" href="https://www.twitter.com/PSXExtreme" title="Twitter" style=""><img src="https://psxextreme.com/wp-content/uploads/2020/06/twitter.png" border="0" width="46" height="46" alt="Twitter" title="Twitter" style="margin:2px;" /></a></li><li class="cn-fa-forums" style="display:inline-block;"><a class=""  href="https://psxextreme.com/forums/" title="Forums" style=""><img src="https://psxextreme.com/wp-content/uploads/2020/06/forums.png" border="0" width="46" height="46" alt="Forums" title="Forums" style="margin:2px;" /></a></li><li class="cn-fa-discord" style="display:inline-block;"><a class="" target="_blank" href="https://discord.gg/TYAUB7Z" title="discord" style=""><img src="https://psxextreme.com/wp-content/uploads/2020/06/Discord-Logo-White.png" border="0" width="46" height="46" alt="discord" title="discord" style="margin:2px;" /></a></li></ul></div><div id="text-3" class="widget_text">			<div class="textwidget"><p><center>©1999-2020 PSX Extreme<br />
BN: 270371669<br />
Something broken or missing? <a href="https://psxextreme.com/about-us/#errorreporter">Report it!</a></center><center><br />
<a href="https://psxextreme.com/advertise/">Advertise </a> |  <a href="https://psxextreme.com/links/">Links </a> |  <a href="https://psxextreme.com/about-us/privacy-policy/">Privacy Policy</a>  |  <a href="https://psxextreme.com/newsletter/">Newsletter </a></center></p>
</div>
</div>            
</div><!-- end of .col-lg-4 -->
</div>
</div><!-- end of #widgets -->
</div>
</div>
<div class="row">
<div class="col-lg-12 scroll-top" style="text-align:right;">
<a href="#scroll-top" title="scroll to top"><i class="fa fa-chevron-up"></i></a>
</div>
</div><!-- end row -->
</div> <!-- end container --> 
</div><!-- end #footer -->
<script type="text/javascript">
jQuery(document).ready(function(){
var wpfcWpfcAjaxCall = function(polls){
if(polls.length > 0){
poll_id = polls.last().attr('id').match(/\d+/)[0];
jQuery.ajax({
type: 'POST', 
url: pollsL10n.ajax_url,
dataType : "json",
data : {"action": "wpfc_wppolls_ajax_request", "poll_id": poll_id, "nonce" : "87688483f0"},
cache: false, 
success: function(data){
if(data === true){
poll_result(poll_id);
}else if(data === false){
poll_booth(poll_id);
}
polls.length = polls.length - 1;
setTimeout(function(){
wpfcWpfcAjaxCall(polls);
}, 1000);
}
});
}
};
var polls = jQuery('div[id^=\"polls-\"][id$=\"-loading\"]');
wpfcWpfcAjaxCall(polls);
});
</script><a href='javascript:void(0);' id='wpdUserContentInfoAnchor' style='display:none;' rel='#wpdUserContentInfo' data-wpd-lity>wpDiscuz</a><div id='wpdUserContentInfo' style='overflow:auto;background:#FDFDF6;padding:20px;width:600px;max-width:100%;border-radius:6px;' class='lity-hide'></div><div id='wpd-editor-source-code-wrapper-bg'></div><div id='wpd-editor-source-code-wrapper'><textarea id='wpd-editor-source-code'></textarea><button id='wpd-insert-source-code'>Insert</button><input type='hidden' id='wpd-editor-uid' /></div><script type='text/javascript' src='https://c0.wp.com/c/5.5.2/wp-includes/js/jquery/ui/core.min.js' id='jquery-ui-core-js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.5.2/wp-includes/js/jquery/ui/widget.min.js' id='jquery-ui-widget-js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.5.2/wp-includes/js/jquery/ui/mouse.min.js' id='jquery-ui-mouse-js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.5.2/wp-includes/js/jquery/ui/sortable.min.js' id='jquery-ui-sortable-js'></script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/9.0.2/_inc/build/photon/photon.min.js' id='jetpack-photon-js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.5.2/wp-includes/js/jquery/ui/datepicker.min.js' id='jquery-ui-datepicker-js'></script>
<script type='text/javascript' id='jquery-ui-datepicker-js-after'>
jQuery(document).ready(function(jQuery){jQuery.datepicker.setDefaults({"closeText":"Close","currentText":"Today","monthNames":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesShort":["Jan","Feb","Mar","Apr","May","Jun","Jul","Aug","Sep","Oct","Nov","Dec"],"nextText":"Next","prevText":"Previous","dayNames":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"dayNamesShort":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"],"dayNamesMin":["S","M","T","W","T","F","S"],"dateFormat":"MM d, yy","firstDay":1,"isRTL":false});});
</script>
<script type='text/javascript' id='bp-nouveau-js-extra'>
/* <![CDATA[ */
var BP_Nouveau = {"ajaxurl":"https:\/\/psxextreme.com\/wp-admin\/admin-ajax.php","confirm":"Are you sure?","show_x_comments":"Show all %d comments","unsaved_changes":"Your profile has unsaved changes. If you leave the page, the changes will be lost.","object_nav_parent":"#buddypress","objects":["activity","members","groups","xprofile","messages","settings","group_members","group_requests"],"nonces":{"activity":"626567895a","members":"43e2040d01","groups":"6fc5663e66","xprofile":"82aec5153d","messages":"1346884d94","settings":"53c7a81c66"}};
/* ]]> */
</script>
<script type='text/javascript' src='https://psxextreme.com/wp-content/plugins/buddypress/bp-templates/bp-nouveau/js/buddypress-nouveau.min.js' id='bp-nouveau-js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.5.2/wp-includes/js/comment-reply.min.js' id='comment-reply-js'></script>
<script type='text/javascript' id='contact-form-7-js-extra'>
/* <![CDATA[ */
var wpcf7 = {"apiSettings":{"root":"https:\/\/psxextreme.com\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"}};
/* ]]> */
</script>
<script type='text/javascript' src='https://psxextreme.com/wp-content/plugins/contact-form-7/includes/js/scripts.js' id='contact-form-7-js'></script>
<script type='text/javascript' id='pt-cv-content-views-script-js-extra'>
/* <![CDATA[ */
var PT_CV_PUBLIC = {"_prefix":"pt-cv-","page_to_show":"5","_nonce":"e7fd55d4ed","is_admin":"","is_mobile":"","ajaxurl":"https:\/\/psxextreme.com\/wp-admin\/admin-ajax.php","lang":"","loading_image_src":"data:image\/gif;base64,R0lGODlhDwAPALMPAMrKygwMDJOTkz09PZWVla+vr3p6euTk5M7OzuXl5TMzMwAAAJmZmWZmZszMzP\/\/\/yH\/C05FVFNDQVBFMi4wAwEAAAAh+QQFCgAPACwAAAAADwAPAAAEQvDJaZaZOIcV8iQK8VRX4iTYoAwZ4iCYoAjZ4RxejhVNoT+mRGP4cyF4Pp0N98sBGIBMEMOotl6YZ3S61Bmbkm4mAgAh+QQFCgAPACwAAAAADQANAAAENPDJSRSZeA418itN8QiK8BiLITVsFiyBBIoYqnoewAD4xPw9iY4XLGYSjkQR4UAUD45DLwIAIfkEBQoADwAsAAAAAA8ACQAABC\/wyVlamTi3nSdgwFNdhEJgTJoNyoB9ISYoQmdjiZPcj7EYCAeCF1gEDo4Dz2eIAAAh+QQFCgAPACwCAAAADQANAAAEM\/DJBxiYeLKdX3IJZT1FU0iIg2RNKx3OkZVnZ98ToRD4MyiDnkAh6BkNC0MvsAj0kMpHBAAh+QQFCgAPACwGAAAACQAPAAAEMDC59KpFDll73HkAA2wVY5KgiK5b0RRoI6MuzG6EQqCDMlSGheEhUAgqgUUAFRySIgAh+QQFCgAPACwCAAIADQANAAAEM\/DJKZNLND\/kkKaHc3xk+QAMYDKsiaqmZCxGVjSFFCxB1vwy2oOgIDxuucxAMTAJFAJNBAAh+QQFCgAPACwAAAYADwAJAAAEMNAs86q1yaWwwv2Ig0jUZx3OYa4XoRAfwADXoAwfo1+CIjyFRuEho60aSNYlOPxEAAAh+QQFCgAPACwAAAIADQANAAAENPA9s4y8+IUVcqaWJ4qEQozSoAzoIyhCK2NFU2SJk0hNnyEOhKR2AzAAj4Pj4GE4W0bkJQIAOw==","is_mobile_tablet":"","sf_no_post_found":"No posts found."};
var PT_CV_PAGINATION = {"first":"\u00ab","prev":"\u2039","next":"\u203a","last":"\u00bb","goto_first":"Go to first page","goto_prev":"Go to previous page","goto_next":"Go to next page","goto_last":"Go to last page","current_page":"Current page is","goto_page":"Go to page"};
/* ]]> */
</script>
<script type='text/javascript' src='https://psxextreme.com/wp-content/plugins/content-views-query-and-display-post-page/public/assets/js/cv.js' id='pt-cv-content-views-script-js'></script>
<script type='text/javascript' src='https://psxextreme.com/wp-content/plugins/pt-content-views-pro/public/assets/js/cvpro.min.js' id='pt-cv-public-pro-script-js'></script>
<script type='text/javascript' src='https://psxextreme.com/wp-content/plugins/wp-autosearch/assert/js/migrate.js' id='wp-autosearch-migrate-js'></script>
<script type='text/javascript' src='https://psxextreme.com/wp-content/plugins/wp-autosearch/assert/js/autocomplete.js' id='wp-autosearch-script-core-js'></script>
<script type='text/javascript' id='wp-autosearch-script-js-extra'>
/* <![CDATA[ */
var wp_autosearch_config = {"autocomplete_taxonomies":"","split_results_by_type":"false","search_title":"true","search_content":"true","search_terms":"false","search_exactonly":"true","order_by":"modified","order":"DESC","search_comments":"false","search_tags":"false","no_of_results":"6","description_limit":"5","title_limit":"50","excluded_ids":{},"excluded_cats":{"0":0},"full_search_url":"https:\/\/psxextreme.com\/?s=%q%","min_chars":"3","ajax_delay":"400","cache_length":"200","autocomplete_sortorder":"posts","thumb_image_display":"true","thumb_image_width":"50","thumb_image_height":"50","get_first_image":"true","force_resize_first_image":"true","thumb_image_crop":"true","default_image":"https:\/\/psxextreme.com\/wp-content\/plugins\/wp-autosearch\/assert\/image\/default.png","search_image":"","display_more_bar":"true","display_result_title":"true","enable_token":"true","custom_css":".wp_autosearch_submit, .wp_autosearch_submit:hover, .wp_autosearch_submit:active, .wp_autosearch_submit:visited {\r\n    cursor: pointer;\r\n    height: 50px;\r\n    width: 54px;\r\n    overflow: hidden;\r\n    background: #1e2836 !important;\r\n    float: right;\r\n    font-size: 100%;\r\n    -webkit-appearance: none;\r\n    outline: none;\r\n    position: absolute;\r\n    right: 0px;\r\n    top: 0px;\r\n    background-color: #1e2836;\r\n    border: none;\r\n    color:#fff;\r\n    border-radius: 0 !important;\r\n    padding: 0 !important;\r\n    margin: 0 !important;\r\n    display: block !important;\r\n}\r\n.wp_autosearch_form_wrapper {\r\n    width: 100%;\r\n    border: 1px solid #ddd !important;\r\n    height: 52px !important;\r\n    background-color: #FFFFFF !important;\r\n    position: relative;\r\n}","custom_js":"","try_full_search_text":"Search more...","no_results_try_full_search_text":"No Results!","show_author":"false","show_date":"false","description_result":"false","color":{"results_even_bar":"E8E8E8","results_odd_bar":"FFFFFF","results_even_text":"000000","results_odd_text":"000000","results_hover_bar":"034478","results_hover_text":"FFFFFF","seperator_bar":"2D8DA0","seperator_hover_bar":"6A81A0","seperator_text":"FFFFFF","seperator_hover_text":"FFFFFF","more_bar":"5286A0","more_hover_bar":"4682A0","more_text":"FFFFFF","more_hover_text":"FFFFFF","box_border":"57C297","box_background":"FFFFFF","box_text":"000000"},"title":{"page":"Pages","post":"Posts","portfolio":"Portfolio"},"post_types":{"0":"post"},"nonce":"84e159d84c","ajax_url":"https:\/\/psxextreme.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://psxextreme.com/wp-content/plugins/wp-autosearch/assert/js/ajax-script.js' id='wp-autosearch-script-js'></script>
<script type='text/javascript' id='wp-polls-js-extra'>
/* <![CDATA[ */
var pollsL10n = {"ajax_url":"https:\/\/psxextreme.com\/wp-admin\/admin-ajax.php","text_wait":"Your last request is still being processed. Please wait a while ...","text_valid":"Please choose a valid poll answer.","text_multiple":"Maximum number of choices allowed: ","show_loading":"1","show_fading":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://psxextreme.com/wp-content/plugins/wp-polls/polls-js.js' id='wp-polls-js'></script>
<script type='text/javascript' id='wpdiscuz-combo-js-js-extra'>
/* <![CDATA[ */
var wpdiscuzAjaxObj = {"wc_hide_replies_text":"Hide Replies","wc_show_replies_text":"View Replies","wc_msg_required_fields":"Please fill out required fields","wc_invalid_field":"Some of field value is invalid","wc_error_empty_text":"please fill out this field to comment","wc_error_url_text":"url is invalid","wc_error_email_text":"email address is invalid","wc_invalid_captcha":"Invalid Captcha Code","wc_login_to_vote":"You Must Be Logged In To Vote","wc_deny_voting_from_same_ip":"You are not allowed to vote for this comment","wc_self_vote":"You cannot vote for your comment","wc_vote_only_one_time":"You've already voted for this comment","wc_voting_error":"Voting Error","wc_comment_edit_not_possible":"Sorry, this comment is no longer possible to edit","wc_comment_not_updated":"Sorry, the comment was not updated","wc_comment_not_edited":"You've not made any changes","wc_msg_input_min_length":"Input is too short","wc_msg_input_max_length":"Input is too long","wc_spoiler_title":"Spoiler Title","wc_cannot_rate_again":"You cannot rate again","wc_not_allowed_to_rate":"You're not allowed to rate here","wc_follow_user":"Follow this user","wc_unfollow_user":"Unfollow this user","wc_follow_success":"You started following this comment author","wc_follow_canceled":"You stopped following this comment author.","wc_follow_email_confirm":"Please check your email and confirm the user following request.","wc_follow_email_confirm_fail":"Sorry, we couldn't send confirmation email.","wc_follow_login_to_follow":"Please login to follow users.","wc_follow_impossible":"We are sorry, but you can't follow this user.","wc_follow_not_added":"Following failed. Please try again later.","is_user_logged_in":"","commentListLoadType":"0","commentListUpdateType":"1","commentListUpdateTimer":"30","liveUpdateGuests":"1","wordpressThreadCommentsDepth":"5","wordpressIsPaginate":"","commentTextMaxLength":null,"commentTextMinLength":"1","storeCommenterData":"100000","socialLoginAgreementCheckbox":"1","enableFbLogin":"0","enableFbShare":"0","facebookAppID":"","facebookUseOAuth2":"0","enableGoogleLogin":"0","googleClientID":"","googleClientSecret":"","cookiehash":"80b5680dd97efbf815e49ed080994b42","isLoadOnlyParentComments":"0","scrollToComment":"1","commentFormView":"collapsed","enableDropAnimation":"1","isNativeAjaxEnabled":"1","enableBubble":"0","bubbleLiveUpdate":"0","bubbleHintTimeout":"45","bubbleHintHideTimeout":"10","cookieHideBubbleHint":"wpdiscuz_hide_bubble_hint","bubbleShowNewCommentMessage":"1","bubbleLocation":"content_left","firstLoadWithAjax":"0","wc_copied_to_clipboard":"Copied to clipboard!","inlineFeedbackAttractionType":"blink","loadRichEditor":"1","wpDiscuzReCaptchaSK":"","wpDiscuzReCaptchaTheme":"light","wpDiscuzReCaptchaVersion":"2.0","wc_captcha_show_for_guest":"0","wc_captcha_show_for_members":"0","wpDiscuzIsShowOnSubscribeForm":"0","wmuEnabled":"1","wmuInput":"wmu_files","wmuMaxFileCount":"1","wmuMaxFileSize":"8388608","wmuPostMaxSize":"67108864","wmuIsLightbox":"1","wmuMimeTypes":{"jpg":"image\/jpeg","jpeg":"image\/jpeg","jpe":"image\/jpeg","gif":"image\/gif","png":"image\/png","bmp":"image\/bmp","tiff":"image\/tiff","tif":"image\/tiff","ico":"image\/x-icon"},"wmuPhraseConfirmDelete":"Are you sure you want to delete this attachment?","wmuPhraseNotAllowedFile":"Not allowed file type","wmuPhraseMaxFileCount":"Maximum number of uploaded files is 1","wmuPhraseMaxFileSize":"Maximum upload file size is 8MB","wmuPhrasePostMaxSize":"Maximum post size is 64MB","msgEmptyFile":"File is empty. Please upload something more substantial. This error could also be caused by uploads being disabled in your php.ini or by post_max_size being defined as smaller than upload_max_filesize in php.ini.","msgPostIdNotExists":"Post ID not exists","msgUploadingNotAllowed":"Sorry, uploading not allowed for this post","msgPermissionDenied":"You do not have sufficient permissions to perform this action","wmuSecurity":"f4fac027b1","wmuKeyImages":"images","wmuSingleImageWidth":"auto","wmuSingleImageHeight":"200","version":"7.0.7","wc_post_id":"48120","loadLastCommentId":"0","isCookiesEnabled":"1","dataFilterCallbacks":[],"is_email_field_required":"1","url":"https:\/\/psxextreme.com\/wp-admin\/admin-ajax.php","customAjaxUrl":"https:\/\/psxextreme.com\/wp-content\/plugins\/wpdiscuz\/utils\/ajax\/wpdiscuz-ajax.php","bubbleUpdateUrl":"https:\/\/psxextreme.com\/wp-json\/wpdiscuz\/v1\/update","restNonce":"7e2dcff60d"};
var wpdiscuzUCObj = {"msgConfirmDeleteComment":"Are you sure you want to delete this comment?","msgConfirmCancelSubscription":"Are you sure you want to cancel this subscription?","msgConfirmCancelFollow":"Are you sure you want to cancel this follow?","additionalTab":"0"};
/* ]]> */
</script>
<script type='text/javascript' id='wpdiscuz-combo-js-js-before'>
var wpdiscuzEditorOptions = {
modules: {
toolbar: "",
counter: {
uniqueID: "",
maxcount : 0,
mincount : 1,
},
},
placeholder: 'Be the First to Comment!',
theme: 'snow',
debug: 'error'
};
</script>
<script type='text/javascript' src='https://psxextreme.com/wp-content/plugins/wpdiscuz/assets/js/wpdiscuz-combo.min.js' id='wpdiscuz-combo-js-js'></script>
<script type='text/javascript' src='https://www.google.com/recaptcha/api.js?render=6Lf2f5UUAAAAAHi81fhnSJr7tBQfAalAhX7yJA65' id='google-recaptcha-js'></script>
<script type='text/javascript' id='wpcf7-recaptcha-js-extra'>
/* <![CDATA[ */
var wpcf7_recaptcha = {"sitekey":"6Lf2f5UUAAAAAHi81fhnSJr7tBQfAalAhX7yJA65","actions":{"homepage":"homepage","contactform":"contactform"}};
/* ]]> */
</script>
<script type='text/javascript' src='https://psxextreme.com/wp-content/plugins/contact-form-7/modules/recaptcha/script.js' id='wpcf7-recaptcha-js'></script>
<script type='text/javascript' src='https://psxextreme.com/wp-content/plugins/jetpack/vendor/automattic/jetpack-lazy-images/src/js/lazy-images.min.js' id='jetpack-lazy-images-js'></script>
<script type='text/javascript' id='wp_slimstat-js-extra'>
/* <![CDATA[ */
var SlimStatParams = {"ajaxurl":"https:\/\/psxextreme.com\/wp-admin\/admin-ajax.php","baseurl":"\/","dnt":"noslimstat,ab-item","oc":"slimstat_optout_tracking","ci":"YTo0OntzOjEyOiJjb250ZW50X3R5cGUiO3M6NDoicG9zdCI7czo4OiJjYXRlZ29yeSI7czo0MzoiMjYsMiwxNTgyNSw3NTAsMTIxNSwyNjQsMTk4LDEyOCwxNTgyNiw1OCw4NCI7czoxMDoiY29udGVudF9pZCI7aTo0ODEyMDtzOjY6ImF1dGhvciI7czoxMjoiQWxleF9Nb3JldHRpIjt9.f14a9bc8a51d5eef742302b8653973ba"};
/* ]]> */
</script>
<script type='text/javascript' src='https://cdn.jsdelivr.net/wp/wp-slimstat/tags/4.8.8.1/wp-slimstat.min.js' id='wp_slimstat-js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.5.2/wp-includes/js/wp-embed.min.js' id='wp-embed-js'></script>
<script>"undefined"!=typeof jQuery&&jQuery(document).ready(function(){"objectFit"in document.documentElement.style==!1&&(jQuery(".cat-post-item figure").removeClass("cat-post-crop"),jQuery(".cat-post-item figure").addClass("cat-post-crop-not-supported")),(document.documentMode||/Edge/.test(navigator.userAgent))&&(jQuery(".cat-post-item figure img").height("+=1"),window.setTimeout(function(){jQuery(".cat-post-item figure img").height("-=1")},0))});</script><script type='text/javascript' src='https://stats.wp.com/e-202044.js' async='async' defer='defer'></script>
<script type='text/javascript'>
_stq = window._stq || [];
_stq.push([ 'view', {v:'ext',j:'1:9.0.2',blog:'143880767',post:'48120',tz:'-4',srv:'psxextreme.com'} ]);
_stq.push([ 'clickTrackerInit', '143880767', '48120' ]);
</script>
<!-- Global site tag (gtag.js) - Google Analytics -->
<script async src="https://www.googletagmanager.com/gtag/js?id=UA-151843729-1"></script>
<script>
window.dataLayer = window.dataLayer || [];
function gtag(){dataLayer.push(arguments);}
gtag('js', new Date());
gtag('config', 'UA-151843729-1');
</script>
</body>
</html><!-- WP Fastest Cache file was created in 0.99678301811218 seconds, on 30-10-20 1:39:39 -->